Modify

Opened 7 years ago

Closed 7 years ago

#2183 closed defect (worksforme)

Exception adding path

Reported by: diroussel Owned by: kisg
Priority: normal Component: SvnAuthzAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I have an existing svn authz file that looks like this:

[groups]
my-commiters = rod,jane,freddy

[/]
* = r
@my-commiters = rw

It didn't work at all prior to changeset:2537 but now I can view the main page in the web admin pages.

The paths do not show up in the GUI, and if I try to add a new path, I get:

Traceback (most recent call last):
  File "d:\Python24\lib\site-packages\trac\web\main.py", line 356, in dispatch_request
    dispatcher.dispatch(req)
  File "d:\Python24\lib\site-packages\trac\web\main.py", line 224, in dispatch
    resp = chosen_handler.process_request(req)
  File "d:\Python24\lib\site-packages\tracwebadmin-0.1.2dev_r3772-py2.4.egg\webadmin\web_ui.py", line 109, in process_request
    path_info)
  File "build\bdist.win32\egg\svnauthz\admin_ui.py", line 78, in process_admin_request
  File "d:\Python24\lib\nturl2path.py", line 55, in pathname2url
    raise IOError, error
IOError: Bad path: myrepo:/

Where my trac.ini looks like:

[trac]
authz_file = D:\work\trac\mytrac.db\access_control.conf
authz_module_name = myrepo
base_url = 
repository_dir = D:\work\svn\repositories\myrepo

Are there some settings I'm missing?

Is it that authz_module_name has to be blank? If so, what other setting to I have to change to make it still work?

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by kisg

  • Resolution set to worksforme
  • Status changed from new to closed

This is not a bug in the plugin. In fact you have to leave the authz_module_name empty, as you suggested.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from kisg. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.