Modify

Opened 7 years ago

Closed 4 years ago

#2195 closed defect (wontfix)

exceptin in log file: 'NoneType' object has no attribute 'get', KeyError: 'trackeywords/htdocs'

Reported by: ThurnerRupert Owned by: mgood
Priority: normal Component: TracPygmentsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

we always get the following error in the logfile, but it anyway seems to work:

2007-11-17 19:33:26,803 Trac[__init__] DEBUG: Pygments Version: 0.9
2007-11-17 19:33:26,895 Trac[main] ERROR: 'NoneType' object has no attribute 'get'
Traceback (most recent call last):
  File "/opt/csw/lib/python/site-packages/trac/web/main.py", line 252, in dispatch
    self._post_process_request(req)
  File "/opt/csw/lib/python/site-packages/trac/web/main.py", line 269, in _post_process_request
    content_type)
  File "build/bdist.solaris-2.10-sun4u/egg/tracpygments/__init__.py", line 134, in post_process_request
AttributeError: 'NoneType' object has no attribute 'get'
2007-11-17 19:33:26,898 Trac[main] ERROR: 'trackeywords/htdocs'
Traceback (most recent call last):
  File "/opt/csw/lib/python/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/opt/csw/lib/python/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/opt/csw/lib/python/site-packages/trac/web/chrome.py", line 226, in process_request
    in provider.get_htdocs_dirs() if dir[0] == prefix]:
  File "build/bdist.solaris-2.10-sun4u/egg/trackeywords/web_ui.py", line 88, in get_htdocs_dirs
    return [('trackeywords', resource_filename(__name__, 'htdocs'))]
  File "/opt/csw/lib/python/site-packages/setuptools-0.6c7-py2.5.egg/pkg_resources.py", line 841, in resource_filename
    self, resource_name
  File "/opt/csw/lib/python/site-packages/setuptools-0.6c7-py2.5.egg/pkg_resources.py", line 1311, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/opt/csw/lib/python/site-packages/setuptools-0.6c7-py2.5.egg/pkg_resources.py", line 1322, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'trackeywords/htdocs'

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by giel

The first error:

2007-11-17 19:33:26,895 Trac[main] ERROR: 'NoneType' object has no attribute 'get'

Is a duplicate of #1336, I'm not sure about the second.

comment:2 Changed 4 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

Closing ticket since plugin is unmaintained and support can be found by upgrading to Trac 0.11.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.