Modify

Opened 7 years ago

Closed 7 years ago

#2281 closed defect (fixed)

Failed Installation; Syntax Error

Reported by: sean.wedig@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords: installation failure
Cc: Trac Release: 0.11

Description

This may be related to #2270, but my symptoms weren't exactly the same, so I'm creating a new ticket. For reference, my setup:

The virtual python 2.3 is because I am on a shared host, and do not have access to update python or install packages.

Anyway, my installation is failing as well. I'm attempting to install via easy_install, as follows:

> easy_install http://trac-hacks.org/svn/timingandestimationplugin/branches/trac0.11

Downloading http://trac-hacks.org/svn/timingandestimationplugin/branches/trac0.11

Doing subversion checkout from http://trac-hacks.org/svn/timingandestimationplugin/branches/trac0.11 to /tmp/easy_install-a07N9v/trac0.11
Processing trac0.11
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-a07N9v/trac0.11/egg-dist-tmp-KlCluM
  File "build/bdist.linux-i686/egg/timingandestimationplugin/tande_filters.py", line 15
    self.billing_reports = set(x[0] for x in cur.fetchall())
                                      ^
SyntaxError: invalid syntax
zip_safe flag not set; analyzing archive contents...
Adding timingandestimationplugin 0.5.7 to easy-install.pth file

Installed /home/[user]/lib/python2.3/site-packages/timingandestimationplugin-0.5.7-py2.3.egg
Processing dependencies for timingandestimationplugin==0.5.7
Finished processing dependencies for timingandestimationplugin==0.5.7

Attempting to do other things with the plugin, such as upgrading the Trac environment, fail with similar syntax errors.

I'm unsure if this is related to Python 2.3, or if it's just the code base. Please let me know if you need other additional information, and I'll do my best to help.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by sean.wedig@…

I installed a local Python 2.5, and went back to re-install everything else. It appears to be the fact that the host is using an old version of Python, and I'm not receiving the syntax error (though I'm not fully installed yet).

However, technically, this is a valid version of Python for Trac 0.11 dev (see: http://trac.edgewall.org/wiki/0.11/TracInstall), so this may still be considered a bug.

comment:2 Changed 7 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

Just FYI we use generator expressions which were only added in python 2.4. Since you seem to have worked around it already, I will close this ticket. Given that python 3000 is in beta, 2.3 is already 2 versions old working on 3. If it becomes a serious issue preventing you from using this, please reopen and I will try to work around this by not using generator expressions.

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.