Modify

Opened 7 years ago

Closed 7 years ago

#2335 closed defect (fixed)

TimingAndEstimationPlugin writes to sys.stdout

Reported by: kjdavies Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

This plugin wants to write to sys.stdout (this is not allowed under mod_wsgi by default; it can be made allowable, but that hides the error). I set sys.stdout to sys.stderr, and now see in /var/log/apache/error_log

[Thu Dec 27 19:28:23 2007] [error] self.billing_reports=set([9, 10, 11, 12, 13, 14, 15, 16, 17])

[Thu Dec 27 19:29:19 2007] [error] self.billing_reports=set([9, 10, 11, 12, 13, 14, 15, 16, 17])

[Thu Dec 27 19:28:23 2007] [error] self.billing_reports=set([9, 10, 11, 12, 13, 14, 15, 16, 17])

[Thu Dec 27 19:29:19 2007] [error] self.billing_reports=set([9, 10, 11, 12, 13, 14, 15, 16, 17])

[Thu Dec 27 19:29:41 2007] [error] self.billing_reports=set([])

[Thu Dec 27 19:29:41 2007] [error] self.billing_reports=set([])

[Thu Dec 27 19:34:25 2007] [error] self.billing_reports=set([])

[Thu Dec 27 19:34:26 2007] [error] self.billing_reports=set([])

The earlier ones are 'working' (reports 10..17), the set([]) ones are the report 9 calls that are failing (as reported in #2334).

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

(In [2948]) re #2334 closes #2335

Fixed error caused by printing to std out rather than to the trac log. There might also be an underlying error, but I cannot recreate it right now (all reports work for me with this version of the plugin).

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.