Modify

Opened 7 years ago

Closed 7 years ago

#2432 closed defect (worksforme)

AttributeError: 'NoneType' object has no attribute 'group'

Reported by: bobbysmith007 Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

I keep getting the error below intermittently. I am running 4 trac instance using this plugin and randomly, they will each fail occasionally with the message below. They seem to work great when not showing this error. I have done everything I could think of to remove any old version of the plugin on the system, so I dont think that is the problem.

I also tried updating to the head trac10 revision, but when I tried, it would not compile (see second error below).

This is pretty important because I have a class full of software engineering students trying to register users and login and occasionally that process just fails inexplicably. I have 'fixed' this problem briefly by resetting the webserver until it decides it wants to work again.

I am running trac 10.5
Python 2.4.4
TracAccountManager-0.1.3dev_r2548-py2.4.egg
Using a htpassword file for auth

Thanks in advance for your help resolving this matter,

Russ

ps. thanks for the great plugin, it is really nice when it is working!


Error from trac log when the plugin fails:

2008-01-17 09:33:01,892 Trac[__init__] ERROR: Cannot find an implementation of the "IPasswordStore" interface named "HtPasswdStore".  Please update the option account-manager.password_store in trac.in\
i.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 182, in dispatch
    req.authname = self.authenticate(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 146, in authenticate
    authname = authenticator.authenticate(req)
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 346, in wrap
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 356, in authenticate
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 382, in _remote_user
  File "build/bdist.linux-i686/egg/acct_mgr/api.py", line 104, in check_password
  File "build/bdist.linux-i686/egg/acct_mgr/api.py", line 120, in password_store
  File "/usr/lib/python2.4/site-packages/trac/config.py", line 379, in __get__
    raise AttributeError('Cannot find an implementation of the "%s" '
AttributeError: Cannot find an implementation of the "IPasswordStore" interface named "HtPasswdStore".  Please update the option account-manager.password_store in trac.ini.

Error when attempting to install head

>sudo python setup.py bdist_egg
running bdist_egg
Traceback (most recent call last):
  File "setup.py", line 39, in ?
    test_suite = 'acct_mgr.tests.suite',
  File "distutils/core.py", line 149, in setup
  File "distutils/dist.py", line 946, in run_commands
  File "distutils/dist.py", line 965, in run_command
  File "/usr/lib/python2.4/cmd.py", line 117, in ensure_finalized
    pass
  File "/usr/lib/python2.4/site-packages/setuptools-0.6b3-py2.4.egg/setuptools/command/bdist_egg.py", line 94, in finalize_options
    ei_cmd = self.ei_cmd = self.get_finalized_command("egg_info")
  File "/usr/lib/python2.4/cmd.py", line 319, in get_finalized_command
    for name in names:
  File "/usr/lib/python2.4/cmd.py", line 117, in ensure_finalized
    pass
  File "/usr/lib/python2.4/site-packages/setuptools-0.6b3-py2.4.egg/setuptools/command/egg_info.py", line 44, in finalize_options
    self.egg_version = self.tagged_version()
  File "/usr/lib/python2.4/site-packages/setuptools-0.6b3-py2.4.egg/setuptools/command/egg_info.py", line 138, in tagged_version
    ):  version += '-r%s' % self.get_svn_revision()
  File "/usr/lib/python2.4/site-packages/setuptools-0.6b3-py2.4.egg/setuptools/command/egg_info.py", line 155, in get_svn_revision
    dirurl = urlre.search(data).group(1)    # get repository URL
AttributeError: 'NoneType' object has no attribute 'group'

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by bobbysmith007

  • Severity changed from critical to blocker
  • Summary changed from Cannot find an implementation of the "IPasswordStore" interface named "HtPasswdStore" to AttributeError: 'NoneType' object has no attribute 'group'

AttributeError: Cannot find an implementation of the "IPasswordStore" interface named "HtPasswdStore". Please update the option account-manager.password_store in trac.ini.

This error seems to have been caused by it being installed as an egg in the local plugins directory rather than globally, though I couldn't tell you why.

I still cannot build the latest revision for the trac 10 branch

-- Russ

comment:2 Changed 7 years ago by mgood

  • Resolution set to worksforme
  • Status changed from new to closed

You need to build it from an SVN checkout since it's configured to append the current SVN revision to the version number of the package.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.