Modify

Opened 7 years ago

Closed 3 years ago

#2463 closed defect (fixed)

Shows non-visited tickets

Reported by: simon@… Owned by: hasienda
Priority: normal Component: BreadCrumbsNavPlugin
Severity: major Keywords: link prefetch
Cc: Trac Release: 0.11

Description

Hi,

I am using the current version of BreadCrumbsNavPlugin and Trac 0.11b1, and i noticed that the plugin displays ticket-crumbs that i haven't visited. The non-visited ticket it displays is always the visited-ticketnum + 1. In other words, if i have visited ticket #402, it will display #402 and #403 too.. This happens for all of our users, and it doesn't happen with wikipages. At first i thought this could be a feature (not documented), but in 99% of the cases the tickets are unrelated so it would be a weird feature. Thank's in advance!

Attachments (1)

prefetch.diff (572 bytes) - added by vasili 'at' techcollective.com 4 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 follow-up: Changed 7 years ago by ixokai

  • Status changed from new to assigned

Are you saying that if you visit #402 for the first time, both #402 and #403 show up right away? What other plugins are you using? The crumbs are 'stored' in a post_process_request so I wonder if there's some plugin interaction going on here.

Also, do you have the latest version? I cleaned up how it handled things in r3065.

comment:2 in reply to: ↑ 1 Changed 7 years ago by simonsolida

Replying to ixokai:

Are you saying that if you visit #402 for the first time, both #402 and #403 show up right away? What other plugins are you using? The crumbs are 'stored' in a post_process_request so I wonder if there's some plugin interaction going on here.

Also, do you have the latest version? I cleaned up how it handled things in r3065.


That is correct, every time i visit a ticket it displays that ticketnumber and the ticketnumber above.. It doesn't happen right away tho, If i visit #402, and then visit any other ticket or wikipage, then it displays #403.

These are the plugins installed at the moment;

TracAccountManager 0.2dev-r2547
TracAuthOpenId 0.1 (not used atm)
TracRevtreePlugin
TracTags 0.6
TracWysiwyg 0.2-r3092

I am using the current version of your plugin, checked out the day after the commit of r3065 (08-01-16)

comment:3 Changed 6 years ago by anonymous

  • Severity changed from normal to major

Seeing the exact same behavior here. Out of all the plugins the OP has installed, I only have tracwysiwyg 0.2 and tracaccountmanager 0.2.1dev-r3857 enabled. It's quite annoying, but the plugin is still great!

Thanks for contributing your work.

comment:4 Changed 6 years ago by ken.latham@…

Not sure if confirmation will help the situation or not ... I am using the latest plugin (from SVN) and production Trac 0.11

Trac:		0.11
Python:		2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
setuptools:	0.6c8
SQLite:		3.3.4
pysqlite:	2.3.2
Genshi:		0.5.1

Configuration
...
components
advancedworkflow.*					enabled
breadcrumbsnavplugin.*					enabled
customfieldadmin.*					enabled
iniadmin.iniadmin.iniadminplugin			enabled
ticketvalidation.*					enabled
ticketvalidator.admin.ticketvalidatoradminpanelprovider	enabled
ticketvalidator.admin.ticketvalidatorchrome		enabled
ticketvalidator.core.requiredfieldvalidator		enabled

In my case, the "extra" ticket numbers are the next higher ticket number than the one selected for whatever query set is active.

For example, if I choose "All Active" and the tickets which display are 1,5,6 and 8, then if I visit 5, 6 is added. If I visit 1, 5 is added. If I visit 8, nothing is added.

There is also nothing added for specific issue queries (through search), since, no doubt, the query consists of only the single issue i.e. there is no "next" issue.

This also happens, as far as I've tested, with all queries regardless of source be it "Search" (#1-10), SQL, "Custom Query" or a predefined report.

Hope this helps some. I can't put this into production the way it is, but I'd really like to be able to, since it would help with my current, uh, "audience". ;)

Ken

P.S. For the record, I do not see any "extra entries" for wiki pages and the like.

comment:5 Changed 5 years ago by anonymous

I think this could be caused by link prefetching. Using Live HTTP headers in Firefox I can see my browser requests the next ticket as defined by the html link tag (<link rel="next").

comment:6 Changed 4 years ago by vasili 'at' techcollective.com

I'm attaching a patch that will make the plugin ignore prefetch requests made by Firefox (it looks for the X-Moz:prefetch" http header).

Changed 4 years ago by vasili 'at' techcollective.com

comment:7 Changed 3 years ago by hasienda

  • Keywords link prefetch added

A similar, but unrelated thing can be observed with the DeveloperLogModule (tracdeveloper.log.*) of TracDeveloperPlugin v0.2 enabled: The last entry of breadcrumbs list is always an entry labeled 'Log' linked to the current page with a '#' appended.

But since this is just a side-effect of debugging technique used, I won't try to fix this one, if no one else complains. This shouldn’t be enabled on a live production system anyway.

comment:8 Changed 3 years ago by hasienda

  • Owner changed from ixokai to hasienda
  • Status changed from assigned to new
  • Summary changed from Shows non-visited tickets. to Shows non-visited tickets

will commit the solution by Vasili as soon as I get priviledges to the SVN repository for this plugin

comment:9 Changed 3 years ago by hasienda

(In [10890]) BreadCrumbsNavPlugin: Don't track prefetched pages, refs #2463.

Not seen in FireFox 3 and later, but better have this to be sure. Thanks to Vasili for contributing this fix.

comment:10 Changed 3 years ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [10896]) BreadCrumbsNavPlugin: Tag long overdue maintenance release 0.2, closes #2463, #3965, #4037, #4411, #7036 and #7231.

Fix erroneously introduced version mismatch between changelog and setup.py.

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.