Modify

Opened 7 years ago

Closed 7 years ago

#2491 closed defect (invalid)

Trac detected an internal error for install fullblog

Reported by: jackie Owned by: osimons
Priority: high Component: FullBlogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Trac detected an internal error:

TemplateNotFound: Template "fullblog_admin.html" not found

If you think this should work you can reproduce the problem, you should consider reporting this to the Trac team.

Before you do that, though, please first try searching for similar issues, as it is quite likely that this problem has been reported before. For questions about installation and configuration of Trac, please try the mailing list instead of filing a ticket.

Otherwise, please ==== How to Reproduce ==== While doing a GET operation on /admin/blog/settings, Trac issued an internal error. (please provide additional details here) Request parameters: {'cat_id': u'blog', 'panel_id': u'settings', 'path_info': None} ==== System Information ====
Trac 0.11b1 Python 2.4.3 (#1, Mar 14 2007, 19:01:42)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
setuptools 0.6c7 SQLite 3.3.6 pysqlite 1.1.7 Genshi 0.5dev-r789 Pygments 0.9 Subversion 1.4.2 (r22196) ==== Python Traceback ==== Traceback (most recent call last): File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 398, in _dispatch_request dispatcher.dispatch(req) File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 217, in dispatch data, content_type) File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 651, in render_template template = self.load_template(filename, method=method) File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 635, in load_template return self.templates.load(filename, cls=cls) File "build/bdist.linux-x86_64/egg/genshi/template/loader.py", line 227, in load TemplateNotFound: Template "fullblog_admin.html" not found a new ticket at the Trac project site, where you can describe the problem and explain how to reproduce it.

Python Traceback
Most recent call last:

  • File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 398, in _dispatch_request Code fragment:
    1. try:
    2. if not env and env_error:
    3. raise HTTPInternalError(env_error)
    4. try:
    5. dispatcher = RequestDispatcher(env)
    6. dispatcher.dispatch(req)
    7. except RequestDone:
    8. pass
    9. resp = req._response or []
    10. except HTTPException, e:
    Local variables: Name Value after [' except RequestDone:', ' pass', ' resp = ... before [' try:', ' if not env and env_error:', ' raise ... dispatcher <trac.web.main.RequestDispatcher object at 0x2ad5d1fd7950> e <genshi.template.loader.TemplateNotFound instance at 0x2ad5d3cc9098> env <trac.env.Environment object at 0x2ad5d0af2710> env_error None exc_info (<class genshi.template.loader.TemplateNotFound at 0x2ad5d02da650>, ... filename '/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py' frames [{'function': '_dispatch_request', 'lines_before': [' try:', ' ... has_admin True line ' dispatcher.dispatch(req)' lineno 397 message u'TemplateNotFound: Template "fullblog_admin.html" not found' req <Request "GET u'/admin/blog/settings'"> resp [] tb <traceback object at 0x2ad5d3cc9170> tb_hide None traceback 'Traceback (most recent call last):\n File ...
  • File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 217, in dispatch Code fragment:
    1. out = StringIO()
    2. pprint(data, out)
    3. req.send(out.getvalue(), 'text/plain')
    4. else:
    5. output = chrome.render_template(req, template,
    6. data, content_type)
    7. # Give the session a chance to persist changes
    8. if req.session:
    9. req.session.save()
    10. req.send(output, content_type or 'text/html')
    Local variables: Name Value chosen_handler <trac.admin.web_ui.AdminModule object at 0x2ad5d1fd7a10> chrome <trac.web.chrome.Chrome object at 0x2ad5d1fb88d0> content_type None data {'dateinfo': <function dateinfo at 0x2ad5d3cc01b8>, 'active_panel': ... err (<class genshi.template.loader.TemplateNotFound at 0x2ad5d02da650>, ... handler <trac.admin.web_ui.AdminModule object at 0x2ad5d1fd7a10> req <Request "GET u'/admin/blog/settings'"> resp ('fullblog_admin.html', {'dateinfo': <function dateinfo at ... self <trac.web.main.RequestDispatcher object at 0x2ad5d1fd7950> template 'fullblog_admin.html'
  • File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 651, in render_template Code fragment:
    1. if content_type is None:
    2. content_type = 'text/html'
    3. method = {'text/html': 'xhtml',
    4. 'text/plain': 'text'}.get(content_type, 'xml')
    5. template = self.load_template(filename, method=method)
    6. data = self.populate_data(req, data)
    7. stream = template.generate(data)
    8. # Filter through ITemplateStreamFilter plugins
    Local variables: Name Value content_type 'text/html' data {'dateinfo': <function dateinfo at 0x2ad5d3cc01b8>, 'active_panel': ... filename 'fullblog_admin.html' fragment False method 'xhtml' req <Request "GET u'/admin/blog/settings'"> self <trac.web.chrome.Chrome object at 0x2ad5d1fb88d0>
  • File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 635, in load_template Code fragment:
    1. if method == 'text':
    2. cls = TextTemplate
    3. else:
    4. cls = MarkupTemplate
    5. return self.templates.load(filename, cls=cls)
    6. def render_template(self, req, filename, data, content_type=None,
    7. fragment=False):
    8. """Render the filename using the data for the context.
    Local variables: Name Value cls <class 'genshi.template.markup.MarkupTemplate'> filename 'fullblog_admin.html' method 'xhtml' self <trac.web.chrome.Chrome object at 0x2ad5d1fb88d0>
  • File "build/bdist.linux-x86_64/egg/genshi/template/loader.py", line 227, in load Local variables: Name Value OSError <exceptions.KeyError instance at 0x2ad5d3cc90e0> cls <class 'genshi.template.markup.MarkupTemplate'> dirname '/var/www/.python-eggs/IniAdmin-0.2-py2.4.egg-tmp/iniadmin/templates' encoding None filename 'fullblog_admin.html' filepath '/var/www/.python-eggs/IniAdmin-0.2-py2.4.egg-tmp/iniadmin/templates/fullbl ... isabs False relative_to None search_path ['/var/www/trac/DNI-Applications/templates', ... self <genshi.template.loader.TemplateLoader object at 0x2ad5d2048390>

File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 398, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 217, in dispatch

data, content_type)

File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 651, in render_template

template = self.load_template(filename, method=method)

File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/chrome.py", line 635, in load_template

return self.templates.load(filename, cls=cls)

File "build/bdist.linux-x86_64/egg/genshi/template/loader.py", line 227, in load

System Information:

User Agent: Mozilla/5.0 (X11; U; Linux x86_64; zh-TW; rv:1.8.0.12) Gecko/20071130 CentOS/1.5.0.12-7.el5.centos Firefox/1.5.0.12
Trac: 0.11b1
Python: 2.4.3 (#1, Mar 14 2007, 19:01:42) [GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
setuptools: 0.6c7
SQLite: 3.3.6
pysqlite: 1.1.7
Genshi: 0.5dev-r789
Pygments: 0.9
Subversion: 1.4.2 (r22196)
jQuery: 1.2.1

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by athomas

  • Component changed from TracHacks to FullBlogPlugin
  • Owner changed from athomas to osimons

comment:2 Changed 7 years ago by osimons

  • Type changed from enhancement to defect

Strange. Looks like it tries to find the template inside your IniAdminPlugin? It really should work.

...filename 'fullblog_admin.html'
filepath '/var/www/.python-eggs/IniAdmin-0.2-py2.4.egg-tmp/iniadmin/templates/fullbl...

Could you try this:

  1. Clean out the FullBlogPlugin from the www/.python-eggs cache, and from site-packages (or wherever it is installed), and reinstall the latest and greatest with:
    easy_install --always-unzip http://trac-hacks.org/svn/fullblogplugin/0.11
    
  2. Disable IniAdminPlugin

Does it work?

comment:3 Changed 7 years ago by theterminator

iam getting exactly the same erroras reported by jackie, i even tried disabling the iniadmin plugin but made no difference

comment:4 Changed 7 years ago by theterminator

just to add the previous ticket i wrotem i checked by trac error logs, and it gives me an error : cant import add_notice, if that helps

comment:5 Changed 7 years ago by athomas

  • Resolution set to invalid
  • Status changed from new to closed

add_notice was added to Trac trunk in t:r6379. You will need at least that version.

Assuming the original posters problem was the same, closing. If this is not the case, feel free to reopen the ticket.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.