Modify

Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#252 closed defect (worksforme)

Output not visible.

Reported by: anonymous Owned by: pkropf
Priority: high Component: GraphvizPlugin
Severity: major Keywords:
Cc: Trac Release: 0.8

Description (last modified by athomas)

I get the following error in trac.log

raise TracError, 'No handler matched request to %s' % req.path_info
TracError: No handler matched request to /site/graphviz/32a4c35133da4624102816e63000d21de146fadd.dot.gif

everything else looks alright.
running version 0.9.4.2 on debian linux

TvM

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by athomas

  • Description modified (diff)

comment:2 Changed 8 years ago by pkropf

  • Trac Release set to 0.8

Can you provide a bit more about your environment?

Which web server? Apache? Tracd?

Can you post your trac.ini file?

comment:3 Changed 8 years ago by pkropf

  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce the problem. Without additional details, I'm going to close this as works for me.

comment:4 Changed 8 years ago by debian4tvm at tiscali dot de

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm running:
Apache/2.0.55 (Debian) mod_auth_pgsql/2.0.3 DAV/2 SVN/1.3.1 mod_python/3.1.3 Python/2.3.5 PHP/5.1.2-1+b1 mod_ssl/2.0.55 OpenSSL/0.9.8a Server at 127.0.0.1 Port 80

My track.ini

 [graphviz]
 prefix_url = /trac/wiki/chrome/site/graphviz
 cache_dir = /opt/trac/cache/graphviz
 cmd_path = /usr/bin
 out_format = jpg
 png_antialias = true
 rsvg_path = /usr/bin/rsvg
 default_graph_fontname = "Andale Mono"
 default_graph_fontsize = 10
 cache_manager = yes
 cache_max_size = 10000000
 cache_min_size = 50000
 cache_max_count = 2000
 cache_min_count = 150

The graphiz !plugin makes an image, it just isn't picked up by trac for some
reason. Pathname perhaps?

When more info is needed, just send me an e-mail.

TvM


comment:5 Changed 8 years ago by debian4tvm at tiscali dot de

  • Resolution set to worksforme
  • Status changed from reopened to closed

After a little research I found that the cache directory can't be freely chosen.
changing it in /opt/trac/htdocs/graphviz/ solved the problem.
Perhaps this needs to be changed in the code someday, the hint graphviz/md5sum.gif isn't
exactly correct.

but it works!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pkropf. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.