Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#2537 closed defect (duplicate)

Can't I install stractistics plugin

Reported by: recena@… Owned by: dagomez
Priority: low Component: StractisticsPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.10

Description

When I try install the plugin, I found this error:

Python Traceback

Traceback (most recent call last):
  File "/usr/local/trac-0.10.4/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/trac-0.10.4/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/STractistics-0.1.0beta-py2.4.egg/stractistics/stractistics.py", line 84, in process_request
    query_response = self._repository_activity(req.args)
  File "/usr/lib/python2.4/site-packages/STractistics-0.1.0beta-py2.4.egg/stractistics/stractistics.py", line 116, in _repository_activity
    weeks_labels, authors_data =  self._authors_commit_data(authors, revisions, start_date, end_date)
  File "/usr/lib/python2.4/site-packages/STractistics-0.1.0beta-py2.4.egg/stractistics/stractistics.py", line 223, in _authors_commit_data
    authors_data[author][week] = authors_data[author][week] + 1
KeyError: '07/53'

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by JirkaV

Hi, sorry I created a duplicate of this ticket (see #2540) - it confirms the bug and offers a temporary fix

comment:2 Changed 6 years ago by dagomez

Hi Jirkav, thank you for the feedback. I'll upload a new version with the fix soon.

comment:3 Changed 6 years ago by dagomez

  • Resolution set to duplicate
  • Status changed from new to closed

Fixed in 0.1.0 tag

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from dagomez. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.