Modify

Opened 6 years ago

Closed 3 years ago

Last modified 14 months ago

#2636 closed defect (fixed)

Installation problems on Ubuntu

Reported by: izzy Owned by: peca
Priority: normal Component: TracDownloaderPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

On Ubuntu (here: 6.06 Dapper Drake, the latest LTS) there are some installation problems due to dependencies: Python (setup.py) looks for "PIL>=1.1.5" and then yields an error:

No local packages or download links found for PIL>=1.1.5
error: Could not find suitable distribution for Requirement.parse('PIL>=1.1.5')

so installation fails. PIL 1.1.5 is installed on the system using apt-get - but the package is called "python-imaging" here (maybe that's the reason). I simply removed the dependency from the setup.py and succeeded with the install (not sure yet if everything works - but I guess it will, since I've got some other plugins installed which also depend on PIL and they work fine so far).

Just in case it is important: Trac 0.10.3, Python 2.4

Attachments (0)

Change History (4)

comment:1 in reply to: ↑ description Changed 6 years ago by peca

  • Resolution set to fixed
  • Status changed from new to closed

Thank you for notice. I've decided to remove automatic dependencies from setup.py, so now there is better description of installation of needed depenedencies in Downloaders Wiki.

Thank you!

Replying to izzy:

On Ubuntu (here: 6.06 Dapper Drake, the latest LTS) there are some installation

problems due to dependencies: Python (setup.py) looks for "PIL>=1.1.5" and then yields an error:

No local packages or download links found for PIL>=1.1.5
error: Could not find suitable distribution for Requirement.parse('PIL>=1.1.5')

so installation fails. PIL 1.1.5 is installed on the system using apt-get - but the package is called "python-imaging" here (maybe that's the reason). I simply removed the dependency from the setup.py and succeeded with the install (not sure yet if everything works - but I guess it will, since I've got some other plugins installed which also depend on PIL and they work fine so far).

Just in case it is important: Trac 0.10.3, Python 2.4

comment:2 Changed 6 years ago by izzy

Thank you! I updated my installation description (http://www.izzysoft.de/?topic=software;page=ifaqmaker.php;id=1) accordingly that here no more "manual adjustment" is necessary.

comment:3 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Humm - despite of your comment, dependencies are still there in setup.py - so installation again failed on Ubuntu Hardy Heron (8.04.01) using Python 2.5! It however succeeded after I removed the lines

  """install_requires = ['PyCAPTCHA >= 0.4',
                         'PIL >= 1.1.5'],"""

from setup.py. I'm still using trac 0.10 (0.10.4 to be more precise), but I guess this will also affect the 0.11 branch since the setup.py looks similar.

By the way: With the latest version, it did not fail because of dependency, but it crashed backtracing to syntax.

comment:4 Changed 3 years ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

This should be fixed on the latest 0.10.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.