Modify

Opened 6 years ago

Closed 6 years ago

#2694 closed defect (worksforme)

Custom Query link does not show

Reported by: jonblow@… Owned by: dgynn
Priority: high Component: BatchModifyPlugin
Severity: blocker Keywords: link
Cc: ian+trac@…, ziondreams+trachacks2694@… Trac Release: 0.11

Description

Hi there
I installed your plugin exactly as you wrote, but can't see "Custom Query" link in the View Tickets menu.

Please fix
Thanks Jon

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by bmoore@…

I'm also seeing this error running against 0.11 trunk as of yesterday. I'm available to help debug/test.

comment:2 Changed 6 years ago by anonymous

I have the same problem.

However, it seems as though it's more of a side effect of the fact that the batch modify plugin isn't even installed.

I've tried installing using easy_install and also manually placing the egg file into the plugins folder, both to no avail.

I wonder if the above behavior is simply because the plugin isn't responding and the instructions say to edit the conf file to disable the query module (assuming this plugin will take over it) and that's why it appears to just make the link disappear.

(tracd server on Windows 2000, if that makes a difference)

comment:3 Changed 6 years ago by anonymous

  • Cc ziondreams+trachacks2694@… added

comment:4 Changed 6 years ago by anonymous

  • Cc ian+trac@… added

Believe I am suffering from the same issue:

Trac 0.11dev-r6750
genshi-0.5dev_r809-py2.5-win32.egg

comment:5 Changed 6 years ago by dgynn

  • Resolution set to fixed
  • Status changed from new to closed

The install instructions for BatchModifyPlugin 0.11 have been updated. Do not disable the Custom Query component with the 0.11 version of the plugin.

comment:6 Changed 6 years ago by ziondreams+trachacks2694@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately, the problem is not fixed (for me anyways.)

Sure, the custom query link reappears if it's not disabled but there's still the problem where it appears the plugin simply isn't installed at all. There's no listing of it in the plugins section, there's no permission added for "TICKET_BATCH_MODIFY" and most importantly, the batch modify section simply doesn't appear below the results on the custom query page.

Is there a problem with installing this plugin? Perhaps it doesn't work correctly on tracd on Windows?

comment:7 Changed 6 years ago by dgynn

  • Owner changed from ashwin_phatak to dgynn
  • Status changed from reopened to new

If the plugin doesn't appear on the Plugin admin panel then it isn't installed correctly. Turn on logging at the debug level and see if the plugin is being loaded at all on startup. Also, if you have TRAC_ADMIN then you won't need to also specify TICKET_BATCH_MODIFY.

See what the log messages say when Trac tries to initialize the component.

comment:8 Changed 6 years ago by dgynn

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from dgynn. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.