Modify

Opened 6 years ago

Closed 6 years ago

#2725 closed defect (worksforme)

HtPasswdStore doesn't work on trac ver 0.11

Reported by: liu.jinzhi@… Owned by: pacopablo
Priority: high Component: AccountManagerPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

set on HtPasswdStore and create a new account, can't login trac and Subversion also can't indentify this user.

Trac version: 0.11b1

account-manager htdigest_realm trac
password_file D:\SVN-Repos\conf\webconfig\svn-auth-file
password_store HtPasswdStore

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by anonymous

  • Owner changed from mgood to anonymous

comment:2 Changed 6 years ago by pacopablo

  • Owner changed from anonymous to pacopablo
  • Status changed from new to assigned

Please make sure that all of the entries in D:\SVN-Repos\conf\webconfig\svn-auth-file look like:

foo:$dj$lajflakjsdf
bar:$sl$Ldjaflkjsdlf

and nor look like:

foo:trac:5b7cb34cbab5ba

comment:3 Changed 6 years ago by liu.jinzhi@…

D:\SVN-Repos\conf\webconfig\svn-auth-file format should be right like.

test:$apr1$y64.....$1L.2zDMDAdgwuqJP2DhQH.
admin:$apr1$.U2.....$jcA3ljXTUxjaPhhHKmzmO0
user1:$apr1$zQTur0..$9si735PJeSsQAn7jFynIF.

comment:4 Changed 6 years ago by pacopablo

Any tracebacks in the log? Are you using form based auth? Or is apache doing the auth?

comment:5 Changed 6 years ago by anonymous

So, I went ahead and installed a test environment (as I normally don't use the HtPasswdStore) and it works fine for me. Here is my setup, you can tell me what is different about yours:

  • Trac 0.11dev-r7168
  • TracAccountManager 0.2dev-r3721
  • trac.ini
    [account-manager]
    password_file = /Users/jchampton/trac-plugin-dev/env/conf/passwd
    password_format = htpasswd
    
    [components]
    acct_mgr.* = enabled
    trac.web.auth.loginmodule = disabled
    
  • Using tracd to serve the environment:
    tracd --port=8080 -s -r .
    

Created initial user with htpasswd. Then created subsequent user via account manager. Was able to log in as both of them successfully

comment:6 Changed 6 years ago by pacopablo

  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing due to lack of response and inability to reproduce the error.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pacopablo. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.