Modify

Opened 6 years ago

Closed 6 years ago

#2741 closed defect (fixed)

SearchAllPlugin does not load in 0.11 Trac due to import error

Reported by: fermulator Owned by: airadier
Priority: normal Component: SearchAllPlugin
Severity: blocker Keywords:
Cc: airadier Trac Release: 0.11

Description

Hey when I try to install SearchAllPlugin it doesn't work. (no checkbox)

Looking at the log file I see:

2008-03-14 14:38:35,739 Trac[loader] ERROR: Skipping "tracsearchall = tracsearchall": (can't import "cannot import name _open_environment")

Is this an easy fix? (I seem to recall these same types of issues with other plugins about the _open_environment is supposed to be changed to open_environment in 0.11.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by alesh.slovak@…

All I did to get SearchAllPlugin to work is make the following change to tracsearchall/searchall.py:

-from trac.web.main import _open_environment
+from trac.web.main import open_environment

i.e. just change "_open_environment" to "open_environment" and it should work in 0.11

comment:2 Changed 6 years ago by fermulator

Confirmed! It works. Should this be applied to the trunk for 0.11 compatibility or would this have a negative effect on backwards compatibility with 0.10?

comment:3 Changed 6 years ago by JasonWinnebeck

  • Summary changed from SearchAllPlugin in 0.11b1 Trac to SearchAllPlugin does not load 0.11 Trac due to import error

Confirmed this is the same situation for 0.11rc1. Alesh: here is actually a line already to import open_environment, so you just need to remove that line.

  • tracsearchall/searchall.py

     
    11## AMB SearchAll - Search multiple trac projects at once 
    22 
    33from trac.core import * 
    4 from trac.web.main import _open_environment 
    54from trac.web.href import Href 
    65try: 
    76    from trac.search import ISearchSource, shorten_result 

comment:4 Changed 6 years ago by JasonWinnebeck

  • Summary changed from SearchAllPlugin does not load 0.11 Trac due to import error to SearchAllPlugin does not load in 0.11 Trac due to import error

comment:5 Changed 6 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from airadier. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.