Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#276 closed defect (fixed)

Approve review results in error

Reported by: daniel.salluce@… Owned by: daniel.salluce@…
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

I refeive the error: "Invalid review ID supplied - unable to load page." when I try to approve/disapprove a code review. Am I doing something wrong or is this a bug?

I get errors like this when I perform most actions after submitting a review.

thanks.

Attachments (0)

Change History (8)

comment:1 Changed 9 years ago by Team5

  • Trac Release set to 0.8

We can't seem to reproduce this error. Can you please provide some more information about the exact steps needed to get it. Thanks.

comment:2 Changed 9 years ago by Team5

Could you also provide the browser/operating system used.

comment:3 Changed 9 years ago by daniel.salluce@…

  • Trac Release changed from 0.8 to 0.9

TRAC version is 0.9.4

I get the "Invalid review ID supplied - unable to load page." error whenever I approve/disapprove a review (basically any function specific to a review ID).

This error occurs on both a Windows XP machine using IE 6.0.2800 or Firefox 1.5.0.1. I can also reproduce the error on Mozilla 1.7.12 under REL WS

I don't think it is a problem on my browser side- there is a similar ticket #233 which suggests editing peerReviewView.cs. I cannot find this file though. Where would I look to find the suggested fix in #233?

thanks for your efforts.

comment:4 Changed 9 years ago by Team5

Thanks for finding this error.

Do you have the most up-to-date version of the plug-in? We changed the filenames to be more consistent across the plug-in.

Also, are you using CGI or FastCGI?

What is the URL in the address bar after this error occurs? (Ex. /peerReviewView?Review=12)

comment:5 Changed 9 years ago by daniel.salluce@…

I'm not sure if this is the correct version number you after (the zip file didn't seem to be labeled anything more than peerreview.zip, but the file installed is: TracCodeReview-0.2-py2.4.egg


The URL looks like this: ...myDomain.../trac/...myProjectName.../viewCodeReview?Review=1&Vote=yes when I try to approve a peer review.


I have no idea how to know what CGI I'm using, but the /etc/apache2/conf.d folder has:

. subversion.conf trac_fastcgi.conf.bak
.. subversion.conf.ldap trac_mod_python.conf.bak
apache2-manual.conf subversion.doc.conf websvn.conf
mailman.conf subversion.viewcvs.conf
php4.conf trac_cgi.conf

Does this mean I'm using CGI and not FastCGI?

thanks

comment:6 Changed 9 years ago by daniel.salluce@…

I was able to get a little more help and find the code being referenced to and make the fix for the approve/disaprove buttons to work with CGI. I do not follow how to make the fix for the Manager privileges though:

<h2>Manager privileges</h2>
Change code review status:
<table valign="middle">
    <tr>
        <td>
            <form method="post" action="">
                <select name="ManagerChoice" id="ManagerChoice">
                    <option value="Open for review">Open for review
                    <option value="Reviewed">Reviewed
                    <option value="Ready for inclusion">Ready for inclusion
                    <option value="Close">Closed
                </select>
                <input type="submit" name="submitbutton" value="Change Status">
            </form>
         </td>
        <td width = 30px></td>
        <td>
            <form method="post" action="<?cs var:trac.href.newCodeReview?>?resubmit=<?cs var:reviewID?>">
            <input type="submit" value="Resubmit For Review">
            </form>
        </td>
    <tr>
</table>
<?cs /if ?>

...right now I get the following error when I submit a manager option: Invalid review ID supplied - unable to load page. ...most likely due to the POST method being wrong as well.

Please help :)

comment:7 Changed 9 years ago by Team5

  • Owner changed from Team5 to daniel.salluce@…

Ok, we just released version 0.3 (it should be in the svn repository in the next few minutes). It has a bunch of bug fixes, and we changed how all the forms on the view code review page operate. We think it should fix the error you were getting - but since we have mod-python on our test apache server, we are not completely sure. Let us know if it works for you now.

Thanks for the feedback!

comment:8 Changed 9 years ago by daniel.salluce@…

  • Resolution set to fixed
  • Status changed from new to closed

Awesome! this fixed my problems and it looks like it works properly with CGI. Thanks for the speedy turnaround- you guys are really on to something here...

Add Comment

Modify Ticket

Action
as closed The owner will remain daniel.salluce@….
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.