Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#2762 closed defect (fixed)

Allow updating status and resolution of multiple tickets

Reported by: ljufis Owned by: ashwin_phatak
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I'm using Trac 0.11b2, BatchModify 0.2 with the patch attached in ticket 2312 (http://trac-hacks.org/ticket/2312)

Updating of all fields excluding status and resolution works OK. Please allow updating of these both fields too.

Attachments (1)

batchmodify.status-resolution.patch (611 bytes) - added by anonymous 6 years ago.
Patch fixes web_ui.py not to ignore status and resolution

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by conny@…

comment:2 Changed 6 years ago by anonymous

I have the same setup, with the jquery patch from #2312 (not the xpath patch) and it fails to update status and resolution. Although the checkboxes work nicely ;)

Changed 6 years ago by anonymous

Patch fixes web_ui.py not to ignore status and resolution

comment:3 follow-up: Changed 6 years ago by anonymous

Sorry I don't know how to make the patch "nicer"... But the problem is on line 57 of web_ui.py, where status and resolution are in the list of fields to ignore when applying modifications. Removing them from the list allows them to be modified.

comment:4 in reply to: ↑ 3 Changed 6 years ago by conny@…

Replying to anonymous:

Sorry I don't know how to make the patch "nicer"...

That works! Perfect! Almost! ;-)

You need to make sure that your users are aware of the fact that this can place tickets in states otherwise deemed invalid since you essentially BYPASS ANY WORKFLOWS you have set up.

I.e. tickets can get stuck like "closed without resolution" as well as "new with resolution".

But in the end - this one together with the -jquery patch takes the BatchModifyPlugin from useless to useful as far as I'm concerned. ;-) Thanks!

comment:5 Changed 6 years ago by anonymous

+1, I need this as well. Of course integrating with workflow would be ideal, but we're OK with it as is.

comment:6 follow-up: Changed 6 years ago by dgynn

  • Resolution set to fixed
  • Status changed from new to closed

Patch applied in changeset:3917. As pointed out by conny, this completely circumvents the workflow system.

comment:7 in reply to: ↑ 6 Changed 5 years ago by anonymous

Replying to dgynn:

Patch applied in changeset:3917. As pointed out by conny, this completely circumvents the workflow system.

I tried making similar changes to web_ui.py for the 0.10 version, but while the status and resolution fields show up, they are not editable (I'm not familiar with the code, so I'm sure I'm missing something). Would it be possible for you to provide a patch for the 0.10 version?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.