Modify

Opened 7 years ago

Closed 7 years ago

#2766 closed defect (invalid)

easy_install gives error

Reported by: ThurnerRupert Owned by: athomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description


Installed /opt/csw/testing/lib/python2.5/site-packages/TracTags-0.6-py2.5.egg
Processing dependencies for TracTags==0.6
Traceback (most recent call last):
  File "/opt/csw/bin/easy_install", line 8, in <module>
    load_entry_point('setuptools==0.6c7', 'console_scripts', 'easy_install')()
  File "/opt/csw/lib/python/site-packages/easy_install.py", line 1670, in main

  File "/opt/csw/lib/python/site-packages/easy_install.py", line 1659, in with_ei_usage

  File "/opt/csw/lib/python/site-packages/easy_install.py", line 1674, in <lambda>

  File "/opt/csw/lib/python/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/opt/csw/lib/python/distutils/dist.py", line 974, in run_commands
    self.run_command(cmd)
  File "/opt/csw/lib/python/distutils/dist.py", line 994, in run_command
    cmd_obj.run()
  File "/opt/csw/lib/python/site-packages/easy_install.py", line 211, in run

  File "/opt/csw/lib/python/site-packages/easy_install.py", line 422, in easy_install

  File "/opt/csw/lib/python/site-packages/easy_install.py", line 473, in install_item

  File "/opt/csw/lib/python/site-packages/easy_install.py", line 519, in process_distribution

  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 529, in resolve
    requirements.extend(dist.requires(req.extras)[::-1])
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2107, in requires
    dm = self._dep_map
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2099, in _dep_map
    for extra,reqs in split_sections(self._get_metadata(name)):
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2518, in split_sections
    for line in yield_lines(s):
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1813, in yield_lines
    for ss in strs:
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2121, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1140, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1137, in get_metadata
    return self._get(self._fn(self.egg_info,name))
  File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1195, in _get
    return self.loader.get_data(path)
zipimport.ZipImportError: bad local file header in /opt/csw/testing/lib/python2.5/site-packages/TracTags-0.6-py2.5.egg

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by athomas

  • Resolution set to wontfix
  • Status changed from new to closed

This looks like a corrupt egg, not a bug in TracTags.

comment:2 Changed 7 years ago by athomas

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:3 Changed 7 years ago by athomas

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.