Modify

Opened 6 years ago

Closed 4 years ago

#2792 closed defect (fixed)

Posting does not work due to SMTP error

Reported by: jouvin@… Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I log to Trac using a certificate and my userid appears as :

logged in as /C=FR/O=CNRS/OU=UMR8607/CN=Michel Jouvin/emailAddress=jouvin@lal.in2p3.fr

I am used to ticket notification not working because of this. But with DiscussionPlugin, it leads to a failure to post to a forum with the following error :

Trac detected an internal error:

SMTPRecipientsRefused: {u'emailAddress=jouvin@lal.in2p3.fr': (550, '5.1.1 <emailAddress=jouvin@lal.in2p3.fr>... User unknown')}

It would be nice if the plugin could check the userid looks as a valid email. In particular something like a certificate DN is easy to identify as it contains / and = that are invalid characters in an email adress. It'd be better to be able to parse such a userid and look for emailAddress if present (not necessarily the case) but this should probably be handled by Trac notification system itself.

Michel

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Blackhex

  • Status changed from new to assigned

0.11 branch will have notification as a component so you could disable it.

comment:2 Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Done with r6261.

comment:4 Changed 4 years ago by Blackhex

  • Resolution set to fixed
  • Status changed from reopened to closed

I suppose it's re-opened by spamer. It's duplicate of #6587 anyway.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.