Modify

Opened 6 years ago

Closed 6 years ago

#2797 closed defect (worksforme)

Text of email overlaps anything below it

Reported by: emailprocessormacro@… Owned by: pacopablo
Priority: normal Component: EmailProcessorMacro
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

The block of text that gets inserted by the macro does not move the rest of the page down, but overlaps it instead.

For instance, if the macro was enabled on this site and I would include an email of several lines and then pressed preview, I would no longer be able to see or reach the Ticket Properties box below and possibly even the Preview and Submit ticket button.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by pacopablo

  • Status changed from new to assigned

Um, I find this a little hard to believe, since it doesn't do that for me. Do you have any better instructions for duplicating the issue? Or perhaps a link to the offending site?

comment:2 Changed 6 years ago by emailprocessormacro@…

Calling me a liar is not the best strategy to acquire my assistance. Also, I am sure you are not the first to find that something that works for you, does not for someone else.

I do not have any better instructions. Include an email of more than say 35 lines, and see if it overlaps the content below. That's what happened here. I took the macro and off line since and restoring it and making the site public will take more time and resources than I can justify right now, sorry.

comment:3 Changed 6 years ago by pacopablo

  • Resolution set to worksforme
  • Status changed from assigned to closed

Let me rephrase:

  1. I can't duplicate this error. It doesn't matter how long of an email I paste into a ticket or a wiki page, it doesn't overlap anything.
  2. The code is such that there is no reason why or how it would overlap anything beneath it.
  3. I don't doubt you experienced what you described, I just don't think it's an issue with the emailprocessormacro due to 1 and 2 above
  4. If you can show me a way to reproduce the error, wonderful, I'll take a look at it. However, as I can't reproduce the error, I can't even begin to fix the problem.
  5. My guess is that the error is due to some other thing. What that thing may be, I don't know.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.