Modify

Opened 6 years ago

Closed 6 years ago

#2900 closed defect (duplicate)

TypeError: cannot return std::string from Unicode object on milestone select

Reported by: yoheeb@… Owned by: khundeen
Priority: normal Component: TracMetrixPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

When clicking on a milestone from the dashbord, I get the following error.

TypeError: cannot return std::string from Unicode object

with the following traceback: file attached, its a long one.

on install I noticed the following warnings:

C:\usr\bin\Python25\lib\site-packages\matplotlib\__init__.py:753: UserWarning:  This call to matplot
lib.use() has no effect
because the the backend has already been chosen;
matplotlib.use() must be called *before* pylab, matplotlib.pyplot,
or matplotlib.backends is imported for the first time.

  warnings.warn(_use_error_msg)
TracMetrix Plugin needs an upgrade
creating cache folder
Done Upgrading
Upgrade done.

but ignored it

and here is my system info trac .11 windows with tracd

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Trac: 	0.11b2
Python: 	2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
setuptools: 	0.6c7
SQLite: 	3.3.4
pysqlite: 	2.3.2
Genshi: 	0.5dev-r826
Subversion: 	1.4.6 (r28521)
jQuery:	1.2.3

Attachments (1)

tracmetrix.txt (6.8 KB) - added by yoheeb@… 6 years ago.
traceback copy

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by yoheeb@…

traceback copy

comment:1 Changed 6 years ago by khundeen

  • Status changed from new to assigned

What matplotlib version are you using?

comment:2 Changed 6 years ago by richardw

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as duplicate of #2504 (the warning log message is related to #3248)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from khundeen. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.