Modify

Opened 6 years ago

Closed 6 years ago

#2906 closed defect (fixed)

Lost all my reports

Reported by: didley@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

After installing the newest plugin I lost all the reports for this plugin. I changed from 0.59 to 0.64. After this trac database has to be upgraded. And now the reports are lost.

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by bobbysmith007

Um... I'm sorry, I hope you had backups if you had modified the reports (though I know thats very little comfort).

Had you modified any of the reports? If so how? Was it just by clicking the 'edit' button. If you didnt modify them it should be easy to get them back.

ONLY DO THIS IF YOU DID NOT HAVE ANY REPORT CUSTOMIZATION

  • Simply connect to the trac database.
  • Check the custom reports table. If there are any rows, for the timing and estimation plugin, you will want to delete those reports and the rows from custom reports.
    • {{{

DELETE FROM report WHERE id in

(SELECT id

FROM custom_report
WHERE maingroup = 'Timing and Estimation Plugin');

DELETE FROM custom_report WHERE maingroup = 'Timing and Estimation Plugin';
}}}

comment:2 Changed 6 years ago by bobbysmith007

  • well crap, I wanted to click preview but did not. That didnt quite look like I wanted it but barring the }}} {{{ it is correct

Once you get the old reports definitely deleted, try upgrading again. Hopefully it will reinstall the reports and everything will be fine.

Please also post

  • what database (and version) you are using
  • the errors reported in the log produced by TracLogging

comment:3 Changed 6 years ago by bobbysmith007

also you might want to checkout #2862 if you are running mysql

comment:4 Changed 6 years ago by didley@…

My configuration:

Trac: 0.11dev 
Python: 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)] 
setuptools: 0.6c6 
SQLite: 3.3.4 
pysqlite: 2.3.2 
Genshi: 0.5dev 
jQuery: 1.2.3

There is no error in the log. The webbrowser got the message when I start from the Managment screen of timing and estimation plugin

{24} Ticket Work Summary 
Reports Must Be Accessed From the Management Screen 

      
Report execution failed: near "_NEW": syntax error
{25} Milestone Work Summary 
Reports Must Be Accessed From the Management Screen 

      
Report execution failed: near "_NEW": syntax error
{26} Developer Work Summary 
Reports Must Be Accessed From the Management Screen 

      
Report execution failed: near "_NEW": syntax error

After cleaning the tables report_custom and report and upgrading the database
The list of available reports are

After Upgrade available reports looks like this

{1}
  Active Tickets
  
{2}
  Active Tickets by Version
  
{3}
  Active Tickets by Milestone
  
{4}
  Assigned, Active Tickets by Owner
  
{5}
  Assigned, Active Tickets by Owner (Full Description)
  
{6}
  All Tickets By Milestone (Including closed)
  
{7}
  My Tickets
  
{8}
  Active Tickets, Mine first
  
{18}
  Admin List
  
{19}
  Open ToDo's (none owner)
  
{20}
  Open ToDo's (none due date)
  
{21}
  Open ToDo's (none topic)
  
{22}
  Franks Tickets

There is no report for the timing and estimation plugin. But when I select * from custom_report

sqlite> select * from custom_report;
23|b24f08c0-d41f-4c63-93a5-25e18a8513c2|Timing and Estimation Plugin|Billing Reports|19|1
24|af13564f-0e36-4a17-96c0-632dc68d8d14|Timing and Estimation Plugin|Billing Reports|16|2
25|7bd4b0ce-da6d-4b11-8be3-07e65b540d99|Timing and Estimation Plugin|Billing Reports|16|3
26|8d785cdb-dcf5-43c9-b2a6-216997b0011a|Timing and Estimation Plugin|Ticket/Hour Reports|14|1
27|71e7c36d-e512-4d0b-b499-087d4d20ff0b|Timing and Estimation Plugin|Ticket/Hour Reports|14|2
28|5f33b102-e6a6-47e8-976c-ac7a6794a909|Timing and Estimation Plugin|Ticket/Hour Reports|14|3
29|7816f034-a174-4a94-aed6-358fb648b2fc|Timing and Estimation Plugin|Ticket/Hour Reports|14|4
30|03815803-7688-4f3a-8e65-8d254cc1d1fb|Timing and Estimation Plugin|Ticket/Hour Reports|14|5
31|040c9025-7641-4d18-96ad-2b26b4095566|Timing and Estimation Plugin|Ticket/Hour Reports|14|6

there are reports.

I didn't customize any report of the plugin so it's not a big problem and I have a three weeks backup of all my projects :-)) But it would to be good if I could have back the reports of the plugin.

didley

comment:5 Changed 6 years ago by bobbysmith007

  • Resolution set to duplicate
  • Status changed from new to closed

That clears this right up. There is currently a bug where trac does not support '_' in variable names in reports. I just need to whip up a patch that removes underscores from status names when creating variable names out of them. I will try to provide a patch by the end of the day.

Duplicate of :2763

comment:6 Changed 6 years ago by bobbysmith007

errr... #2763

comment:7 follow-up: Changed 6 years ago by didley@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Now I changed timingandestimationplugin from 0.6.5 to 0.6.6. I changed just only the egg_file. I made a new upgrade for my environment.

Now I get this logfile. There are no Reports available in the menue viewTickets but in the select * from custom_report.

2008-06-25 11:45:45,688 Trac[reportmanager] ERROR: add_report b24f08c0-d41f-4c63-93a5-25e18a8513c2 (ver:20) | id: None currentversion: 0
2008-06-25 11:45:45,766 Trac[reportmanager] ERROR: add_report af13564f-0e36-4a17-96c0-632dc68d8d14 (ver:17) | id: None currentversion: 0
2008-06-25 11:45:45,861 Trac[reportmanager] ERROR: add_report 7bd4b0ce-da6d-4b11-8be3-07e65b540d99 (ver:17) | id: None currentversion: 0
2008-06-25 11:45:45,938 Trac[reportmanager] ERROR: add_report 8d785cdb-dcf5-43c9-b2a6-216997b0011a (ver:15) | id: None currentversion: 0
2008-06-25 11:45:46,049 Trac[reportmanager] ERROR: add_report 71e7c36d-e512-4d0b-b499-087d4d20ff0b (ver:15) | id: None currentversion: 0
2008-06-25 11:45:46,127 Trac[reportmanager] ERROR: add_report 5f33b102-e6a6-47e8-976c-ac7a6794a909 (ver:15) | id: None currentversion: 0
2008-06-25 11:45:46,220 Trac[reportmanager] ERROR: add_report 7816f034-a174-4a94-aed6-358fb648b2fc (ver:15) | id: None currentversion: 0
2008-06-25 11:45:46,299 Trac[reportmanager] ERROR: add_report 03815803-7688-4f3a-8e65-8d254cc1d1fb (ver:15) | id: None currentversion: 0
2008-06-25 11:45:46,391 Trac[reportmanager] ERROR: add_report 040c9025-7641-4d18-96ad-2b26b4095566 (ver:15) | id: None currentversion: 0

comment:8 in reply to: ↑ 7 Changed 6 years ago by bobbysmith007

Replying to didley@gmx.de:

Now I get this logfile. There are no Reports available in the menue viewTickets but in the select * from custom_report.

  • Are the reports in the reports / custom_reports tables?

I seem to have had a log.error where there should have been a log.debug, so those errors were just logging the curenrt state of everything upon attempting to upgrade the reports. Meaning there should be reports in both the custom_reports and the reports table.

Also you know that you are supposed to access those reports via the Management page correct? In the trac 11 version this plugin it hides the reports on the report page since they will not work when accessed from there.

Hope this helps,

Russ

comment:9 Changed 6 years ago by didley@…

Now I finished a workaround. I did uninstall all timingandestimation plugins from my environments. I did delete all entries in report and custom_report table where maingroup are 'Timing and Estimation Plugin'. After this I did start trac again so as to see are realy no plugin in it.

After this I installed the plugin global and accomplished a upgrade. Now see the content of the tables report / custom_report

sqlite> select id, title from report;
1|Active Tickets
2|Active Tickets by Version
3|Active Tickets by Milestone
4|Assigned, Active Tickets by Owner
5|Assigned, Active Tickets by Owner (Full Description)
6|All Tickets By Milestone  (Including closed)
7|My Tickets
8|Active Tickets, Mine first
18|Admin List
19|Open ToDo's (none owner)
20|Open ToDo's (none due date)
21|Open ToDo's (none topic)
22|Franks Tickets
23|Ticket Work Summary
24|Milestone Work Summary
25|Developer Work Summary
26|Ticket Hours
27|Ticket Hours with Description
28|Ticket Hours Grouped By Component
29|Ticket Hours Grouped By Component with Description
30|Ticket Hours Grouped By Milestone
31|Ticket Hours Grouped By MileStone with Description
sqlite> select * from custom_report;
23|b24f08c0-d41f-4c63-93a5-25e18a8513c2|Timing and Estimation Plugin|Billing Reports|20|1
24|af13564f-0e36-4a17-96c0-632dc68d8d14|Timing and Estimation Plugin|Billing Reports|17|2
25|7bd4b0ce-da6d-4b11-8be3-07e65b540d99|Timing and Estimation Plugin|Billing Reports|17|3
26|8d785cdb-dcf5-43c9-b2a6-216997b0011a|Timing and Estimation Plugin|Ticket/Hour Reports|15|1
27|71e7c36d-e512-4d0b-b499-087d4d20ff0b|Timing and Estimation Plugin|Ticket/Hour Reports|15|2
28|5f33b102-e6a6-47e8-976c-ac7a6794a909|Timing and Estimation Plugin|Ticket/Hour Reports|15|3
29|7816f034-a174-4a94-aed6-358fb648b2fc|Timing and Estimation Plugin|Ticket/Hour Reports|15|4
30|03815803-7688-4f3a-8e65-8d254cc1d1fb|Timing and Estimation Plugin|Ticket/Hour Reports|15|5
31|040c9025-7641-4d18-96ad-2b26b4095566|Timing and Estimation Plugin|Ticket/Hour Reports|15|6

In the view Tickets page of trac I can see these reports

{1}   	 Active Tickets
{2} 	Active Tickets by Version
{3} 	Active Tickets by Milestone
{4} 	Assigned, Active Tickets by Owner
{5} 	Assigned, Active Tickets by Owner (Full Description)
{6} 	All Tickets By Milestone (Including closed)
{7} 	My Tickets
{8} 	Active Tickets, Mine first
{18} 	Admin List
{19} 	Open ToDo's (none owner)
{20} 	Open ToDo's (none due date)
{21} 	Open ToDo's (none topic)
{22} 	Franks Tickets

From the management page of timingandestimationplugin I can use the reports. The only thing is now I can't see the reports in the view ticket page of trac. It seems so. The logfile has the same content (error add report etc) as before.

comment:10 Changed 6 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from reopened to closed

Glad you got it worked out as noted above:

In the trac 11 version this plugin it hides the reports on the report page since they will not work when accessed from there.

You can disable this feature by turning of the tande_filters module but this will also turn off some other things which may not be so desirable.

Hope this helps,

Russ

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.