Modify

Opened 7 years ago

Closed 6 years ago

#2943 closed defect (fixed)

Filename listed in download list should not include the uploader's local directory path

Reported by: anonymous Owned by: Blackhex
Priority: normal Component: DownloadsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

After uploading a file using the DownloadsPlugin admin page, the file becomes listed using the absolute pathname, as uploaded by the uploader. This includes the local directories where the uploaded file lived as it was uploaded. The directory path should be stripped as it reflects the uploaders directory structure and is not relevant, and most likely unrelated to any downloader's directory structure.

Attachments (1)

trac_downloads_plugin_bug.jpg (50.2 KB) - added by eswenson 7 years ago.
Screen shot of downloads view with full path of uploaded file displayed

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by Blackhex

  • Status changed from new to assigned

Which UA on which OS? Which server on which OS? Please.

comment:2 Changed 7 years ago by anonymous

I'm using Internet Explorer 7, on Windows XP SP2.

There is a further problem -- not only are the downloads listed using the absolute pathname of the file (as it was uploaded), but the file ends up being stored somewhere other than the location as configured by the [downloads] "path" setting. I think this is because the pathname (as it comes from the upload) is being interpreted as the location to store the uploaded entry on the trac server.

comment:3 Changed 7 years ago by eswenson

I've just registered on the site, but I'm the guy who submitted this ticket.

I forgot to provide you the information that the server machine is also a Windows XP SP2 machine and the server is tracd. (I'm actually evaluating this plugin for use on an apache-based trac instance, where it fails in the same way, but was doing testing on my local (Windows) machine, which is just using tracd). If you cannot reproduce, I'll get some screen shots and upload them tomorrow.

Changed 7 years ago by eswenson

Screen shot of downloads view with full path of uploaded file displayed

comment:4 Changed 7 years ago by Blackhex

OK, thx. I hope that it is a Windows UA (I don't test on Windows) which gives full path. I'll append stripping of this later this day...

comment:5 follow-up: Changed 7 years ago by Blackhex

Please test it with r3545.

comment:6 in reply to: ↑ 5 Changed 7 years ago by eswenson

Replying to Blackhex:

Please test it with r3545.

It worked perfectly. Thanks much. -- Eric

comment:7 Changed 6 years ago by Blackhex

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain Blackhex.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.