Modify

Opened 9 years ago

Closed 9 years ago

Last modified 10 months ago

#296 closed defect (fixed)

Email from OWA doesn't create ticket

Reported by: greg.deakyne@… Owned by: bas
Priority: normal Component: EmailtoTracScript
Severity: normal Keywords: OWA
Cc: Trac Release: 0.9

Description

When emailing the address on my trac machine that then runs run_email2trac, I get the following error below. This error only occurs when emailing from Outlook Web Access 2003. I've tried this from two seperate OWA systems. The run_email2trac works fine when emailed from the outlook client

< luigi.etapestry.com #5.0.0 X-Postfix; Command died with status 1:    "/usr/local/bin/run_email2trac". Command output: TD: saving email to    /var/tmp/msg.txt TD: part1: Content-Type: text/html TD: part1: filename:    None TD: this part is not multipart TD: writing part1 (/var/tmp/part1)   Traceback (most recent call last):   File "/usr/local/bin/email2trac", line    644, in ?     tktparser.parse(sys.stdin)  File    "/usr/local/bin/email2trac", line 354, in parse    self.description(msg,tkt, head, author, email_addr)  File    "/usr/local/bin/email2trac", line 420, in description     mailto =    self.html_mailto_link(author, email, self.to_unicode(msg['subject']),    ubody_text) UnboundLocalError: local variable 'ubody_text' referenced    before assignment>

Attachments (2)

msg.txt (2.2 KB) - added by greg.deakyne@… 9 years ago.
part1 (353 bytes) - added by greg.deakyne@… 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by greg.deakyne@…

Changed 9 years ago by greg.deakyne@…

comment:1 Changed 9 years ago by bas

  • Status changed from new to assigned

This a bug, here is a small patch, fixed in trunk version:

# svn diff
Index: email2trac.py.in
===================================================================
--- email2trac.py.in    (revision 570)
+++ email2trac.py.in    (working copy)
@@ -380,6 +380,7 @@
                message text can be plain text or html or something else
                """
                has_description = 0
+               ubody_text = '\n{{{\nNo plain text message\n}}}\n'
                for part in msg.walk():

                        # 'multipart/*' is a container for multipart messages

comment:2 Changed 9 years ago by greg.deakyne@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Checked out new trunk version with applied patch above and it worked.

comment:3 Changed 9 years ago by bas

  • Resolution fixed deleted
  • Status changed from closed to reopened

I reopen it till i release a new version that fixes the problem. Thanks for testing

comment:4 Changed 9 years ago by bas

  • Resolution set to fixed
  • Status changed from reopened to closed

Is fixed in new version and trunk

Add Comment

Modify Ticket

Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.