Modify

Opened 7 years ago

Closed 7 years ago

#3063 closed defect (fixed)

UnboundLocalError: local variable 'groups_dict' referenced before assignment

Reported by: anonymous Owned by: robert_martin
Priority: normal Component: FineGrainedPageAuthzEditorPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

after clicking on the Link to the editor (in the admin menu):

Trac detected an internal error: UnboundLocalError: local variable 'groups_dict' referenced before assignment

File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r7086-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r7086-py2.4.egg/trac/web/main.py", line 197, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r7086-py2.4.egg/trac/admin/web_ui.py", line 109, in process_request

path_info)

File "build/bdist.linux-i686/egg/page_authz_policy_editor/pape_admin.py", line 105, in render_admin_panelFile "build/bdist.linux-i686/egg/page_authz_policy_editor/pape_admin.py", line 97, in _get_groups_and_members

System Information:

User Agent: Opera/9.50 (X11; Linux x86_64; U; en)Trac: 0.11dev-r7086 Python: 2.4.4 (#1, Apr 15 2008, 23:37:53) [GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)] setuptools: 0.6c6 SQLite: 3.3.8 pysqlite: 2.3.2 Genshi: 0.4.4 mod_python: 3.2.10 Subversion: 1.4.2 (r22196) jQuery: 1.2.3

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by robert_martin

  • Status changed from new to assigned

comment:2 Changed 7 years ago by robert_martin

  • Status changed from assigned to new

comment:3 Changed 7 years ago by robert_martin

  • Resolution set to fixed
  • Status changed from new to closed
  • Trac Release changed from 0.10 to 0.11

groups_dict is now instantiated before the first conditional in _get_groups_and_members. If there was no group file then the check of having the entries caused an exception, rather than handling it gracefully as intended.

Add Comment

Modify Ticket

Action
as closed The owner will remain robert_martin.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.