Modify

Opened 6 years ago

Closed 16 months ago

#3064 closed defect (fixed)

[Patch] Plugin does not show up in trac admin

Reported by: anonymous Owned by: deltroo
Priority: highest Component: SearchAttachmentsPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

This plugin does not appear to be working, nor does it show up in the Trac plugins list on the trac-admin page after installation.

I am running a Windows 2003 Server with Trac 0.11b2 and Python 2.5. All necessary application dependencies (swish-e, catdoc, catppt, pdftotext) are installed.

The .egg file was compiled using the "python setup.py bdist_egg" command, and then copied to the environment's plugin directory. Necessary changes were made to the trac.ini file [components] and [attachment] secionts, but the plugin still does not show up.

I have also attempted to install this as a global plugin, but that has not worked either.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by kennethxu

  • Type changed from defect to enhancement

I think the problem is simply because this plugin doesn't support 0.11. Any plan to support 0.11. I loved this plugin and will be missing it...

comment:2 Changed 6 years ago by wouter

  • Type changed from enhancement to defect

I have exactly the same problem here. Running Windows 2003 Server too, using Trac 0.11b1 and Python 2.5... Does not show up in the admin either, uploading new attachments does not create new index files, I put the config in the [attachment] section instead of [attachments] as dictated by the wiki, after checking in the plugin's code which section it would look at. Still does not work.

Probably because the plugin simply doesn't get picked up by Trac?

comment:3 Changed 6 years ago by wouter

Additionally, here is what I see in the log file:

2008-10-02 12:13:34,717 Trac[loader] DEBUG: Loading TracSearchAttachmentsPlugin from c:\repositories\sandbox-trac\plugins\tracsearchattachmentsplugin-0.1-py2.5.egg
2008-10-02 12:13:34,717 Trac[loader] ERROR: Skipping "TracSearchAttachmentsPlugin = searchattachments": (can't import "bad local file header in c:\repositories\sandbox-trac\plugins\tracsearchattachmentsplugin-0.1-py2.5.egg")

I can view the file with a ZIP viewer though.

comment:4 Changed 6 years ago by anonymous

I believe I've found the problem in searchattachments/searchattachments.py line 13:

from trac.Search import ISearchSource

should be:

from trac.search import ISearchSource

When I made this change, the plugin showed up in the admin page of a trac 0.11 installation, and seemed capable of finding terms in pdf files.

I hope someone can confirm and check this change in to the code repository.

comment:5 Changed 5 years ago by rjollos

  • Summary changed from Plugin does not show up in trac admin to [Patch] Plugin does not show up in trac admin

comment:6 Changed 16 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [13178]) Fixes #3064: Fixed incorrect import.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.