Modify

Opened 8 years ago

Closed 8 years ago

#311 closed enhancement (duplicate)

Adding new users only by TRAC_ADMIN

Reported by: marcin@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

Hello,

I think it would be a good idea to enable adding new users (entries in htpasswd) only by TRACADMIN and with possibility to disable self-registration. For instance via webadmin interface.
Regards

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by anonymous

  • Type changed from defect to enhancement

comment:2 Changed 8 years ago by athomas

trac-admin currently has no way of extending its behaviour, making this impossible.

comment:3 Changed 8 years ago by anonymous

so adding and deleting users from trac isn't possible? I don't believe it.
How about authz editor plugin? It checks if user has TRAC_ADMIN permission and then gives possibility to change svn ACL files. I think that manipulating htpasswd could be done at least the same way or better via simply interface. Regards

comment:4 Changed 8 years ago by Marcin Hlybin, marcin@…

sorry I didn't change username ;)

comment:5 Changed 8 years ago by athomas

Ah, I misunderstood. I thought you were referring to the trac-admin command line utility. Disregard.

comment:6 Changed 8 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

Please check for existing tickets before opening a new one. This is a duplicate of #20.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.