Modify

Opened 6 years ago

Closed 6 years ago

#3118 closed defect (fixed)

Incompatible with 0.11rc1?

Reported by: wbranderson@… Owned by: proofek
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords: unknown encoding
Cc: Trac Release: 0.11

Description

I attempted each of the following installations of the PeerReview Plugin:

First:
easy_install http://www.trac-hacks.org/svn/peerreviewplugin/0.11

Second:
easy_install http://www.trac-hacks.org/svn/peerreviewplugin/trunk/

And then added the following line to my trac.ini file:

[components]
codereview.* = enabled

Both times I received the following error message when attempting to access the Trac environment in which the plugin was enabled:

Traceback (most recent call last):

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\web\api.py", line 339, in send_error

'text/html')

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\web\chrome.py", line 684, in render_template

data = self.populate_data(req, data)

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\web\chrome.py", line 592, in populate_data

dchrome?.update(req.chrome)

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\web\api.py", line 168, in getattr

value = self.callbacks[name](self)

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\util\compat.py", line 130, in newfunc

return func_(*(args + fargs), dict(kwargs, fkwargs))

File "c:\python24\lib\site-packages\Trac-0.11rc1-py2.4.egg\trac\web\chrome.py", line 460, in prepare_request

for category, name, text in contributor.get_navigation_items(req):

File "build\bdist.win32\egg\codereview\peerReviewMain.py", line 36, in get_navigation_items

LookupError: unknown encoding: /InternalProcesses/peerReviewMain

Please advise! I still have clearsilver-0.9.14-py2.4-win32.egg in my site-packages directory, fyi.

Brett

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 6 years ago by proofek

  • Status changed from new to assigned

This is caused by an issue described in http://trac.edgewall.org/ticket/7255. I am gonna release an updated version of the plugin for both version 2.0dev (0.11 and trunk) and 2.1-toddler. Stay tuned.

Btw. it works for with rc1 and trunk version - it might be python version thou - I am using 2.5 at my dev machine.

comment:2 in reply to: ↑ 1 Changed 6 years ago by wbranderson@…

Replying to proofek:

This is caused by an issue described in http://trac.edgewall.org/ticket/7255. I am gonna release an updated version of the plugin for both version 2.0dev (0.11 and trunk) and 2.1-toddler. Stay tuned.

Btw. it works for with rc1 and trunk version - it might be python version thou - I am using 2.5 at my dev machine.

It could be a Python version problem. However, I'd like to stick with 2.4 since my entire configuration relies on. Keep me posted!

comment:3 Changed 6 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

That's now been fixed and committed to the following:

  • trunk
  • 0.11
  • 2.1-toddler

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from proofek. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.