Modify

Opened 7 years ago

Closed 7 years ago

#3158 closed defect (invalid)

IntegrityError and login as somebody else

Reported by: mehmet@… Owned by: mgood
Priority: high Component: AccountManagerPlugin
Severity: blocker Keywords:
Cc: mehmet@… Trac Release: 0.11

Description

Sometimes, trying to login we get an error similar to below message

IntegrityError: (1062, "Duplicate entry '19c3c13591ddaf8cfba741a3923d8600-88.250.85.216-mehmet' for key 1")

Also there are times when all of a sudden I realize that I am logged in as a colleague of mine. I try to log out and log back in as myself and get the above message or if I am successful this time my colleague switches to my username.

I have not been able to find the exact pattern to repeat the problem, but it occurs quite often when multiple people are working.

By the way, we are all working from the same office which is connected to the Internet from one ip address using NAT and the trac server is on outside network. I believe part of the problem is related to this.

[components]
trac.web.auth.LoginModule = disabled
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.htfile.htdigeststore = enabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.LoginModule = enabled
tracext.git.* = enabled

[account-manager]
password_format = htdigest
password_file = /trac/trac.htdigest
htdigest_realm = trac

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

  • Cc mehmet@… added; anonymous removed

comment:2 Changed 7 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

I no longer think this is related to AccountManagerPlugin as I was able to repeat the problem without it. I opened a ticket at http://trac.edgewall.org/ticket/7321

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.