Modify

Opened 6 years ago

Closed 6 years ago

#3221 closed defect (invalid)

After installing Announcer I got an error

Reported by: helge@… Owned by: clp
Priority: normal Component: AccountLdapPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

Available Projects
drift: Error
(The Trac Environment needs to be upgraded. Run "trac-admin /srv/trac/drift upgrade")

Then I tried to run upgrade and got a new error:
[root@test drift]# trac-admin /srv/trac/drift upgrade
Command failed: No module named trac.db
[root@test drift]#

How do I fix this?

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by mpaiu@…

  • Component changed from AnnouncerPlugin to AccountLdapPlugin
  • Owner changed from ixokai to clp
  • Severity changed from normal to blocker

I have also update trac from version 0.10.4 to 0.11 and I get the same error:

[root@hydrogen trac_repository]# trac-admin /www/svn/messaging/trac_repository upgrade
Command failed: No module named trac.db

Please, I moved the Priority to HIGHEST since it is urgent .

comment:2 Changed 6 years ago by mpaiu@…

  • Priority changed from highest to normal

I disabled all plugins I have installed into TRAC and the upgrade worked...

Maybe it will help you also, the one that opened this ticket :)

Regards, Mihai

comment:3 Changed 6 years ago by clp

  • Resolution set to invalid
  • Status changed from new to closed

When you update TRAC, you have to update the plugins too.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.