Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3224 closed defect (duplicate)

AttributeError: 'array.array' object has no attribute 'replace'

Reported by: anonymous Owned by: osimons
Priority: normal Component: FullBlogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by osimons)

After trying to send my first blog entry, It fails with an error previousli submited by me, and now not only the blog, but the wiki and the timeline is also dead. This is when I click on the blog on the main bar.

How to Reproduce

While doing a GET operation on /blog, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'blog_path': ''}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9) Gecko/2008052906 Firefox/3.0

System Information

Trac 0.11rc2
Python 2.4.4 (#2, Apr 15 2008, 23:43:20)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c3
MySQL server: "5.0.32-Debian_7-log", client: "5.0.32", thread-safe: 1
MySQLdb 1.2.1_p2
Genshi 0.6dev-r888
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc2-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc2-py2.4.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/TracFullBlogPlugin-0.1-py2.4.egg/tracfullblog/web_ui.py", line 136, in process_request
    blog_posts = get_blog_posts(self.env)
  File "/usr/lib/python2.4/site-packages/TracFullBlogPlugin-0.1-py2.4.egg/tracfullblog/model.py", line 137, in get_blog_posts
    categories = _parse_categories(row[6])
  File "/usr/lib/python2.4/site-packages/TracFullBlogPlugin-0.1-py2.4.egg/tracfullblog/model.py", line 256, in _parse_categories
    categories = categories.replace(',', ' ') # drop commas
AttributeError: 'array.array' object has no attribute 'replace'

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by osimons

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #3223 - one ticket should be sufficient to track the issue.

comment:2 Changed 6 years ago by dlbrant

  • Cc stitch_@… removed
  • Description modified (diff)

comment:3 Changed 6 years ago by dlbrant

  • Priority changed from normal to highest

comment:4 Changed 6 years ago by osimons

  • Description modified (diff)
  • Priority changed from highest to normal
  • Severity changed from blocker to normal

Please don't use this Trac for testing.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from osimons. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.