Modify

Opened 6 years ago

Closed 6 years ago

#3248 closed defect (fixed)

UserWarning when start a tracd of poroject with DashBoard

Reported by: lustin@… Owned by: richardw
Priority: low Component: TracMetrixPlugin
Severity: minor Keywords: warning tracd
Cc: Trac Release: 0.11

Description (last modified by khundeen)

i dont know may be it's not important, [BR] but when i run tracd, on project with TracMetrixPlugin i have this messages

Server starting in PID 9389.
Serving on 0.0.0.0:80 view at http://127.0.0.1:80/
/usr/lib/python2.5/site-packages/matplotlib/__init__.py:755: UserWarning:  This call to matplotlib.use() has no effect
because the the backend has already been chosen;
matplotlib.use() must be called *before* pylab, matplotlib.pyplot,
or matplotlib.backends is imported for the first time.

  warnings.warn(_use_error_msg)

PS Python:2.5.2 (r252:60911, Apr 21 2008, 11:12:42) [GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)]

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by richardw

  • Resolution set to duplicate
  • Status changed from new to closed

This looks like a duplicate of #2900

comment:2 Changed 6 years ago by richardw

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, not a duplicate after all. #2900 is describing a different bug, but the description contains mention of this warning.

comment:3 Changed 6 years ago by richardw

  • Owner changed from khundeen to richardw
  • Status changed from reopened to new

comment:4 Changed 6 years ago by richardw

  • Status changed from new to assigned

comment:5 Changed 6 years ago by richardw

I've moved all the graph generation code to the web_ui module and this seems to get rid of the matplotlib warning message. I also took the opportunity to move the mdashboard code into the web_ui, and model modules. It seemed unnecessary to have a separate module. See:

comment:6 Changed 6 years ago by khundeen

Thanks for investigating on this. I think matplotlib has been quite a problem for us. I am thinking about changing to Open flash chart (http://teethgrinder.co.uk/open-flash-chart/) but am not sure when I will get around to do it. Does anyone have any experience with it? I hope it's easy to move. Then we don't really need to numpy and matplotlib to use TracMetrix.

comment:7 Changed 6 years ago by khundeen

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from assigned to closed

Please try the new version. This problem should go away.

Add Comment

Modify Ticket

Action
as closed The owner will remain richardw.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.