Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#3440 closed task (invalid)

Updating the Status of a Trac ticket via a SVN commit

Reported by: cuong <duccuongbui8955@…> Owned by: k0s
Priority: normal Component: SvnChangeListenerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

One of the really nice things about the SVN/Trac combo is that when you commit changes to SVN, you can have the changeset update the status of a Trac ticket.

I am trying to integrate subversion and trac. I am using the post
commit hook script found at
http://trac.edgewall.org/browser/branches/0.10-stable/contrib/trac-post-commit-hook
to be able to modify tickets and in my post-commit.tmpl in my svn i
have

REPOS="$1"
REV="$2"
LOG=C:\Program Files\Subversion\bin\svnlook log -r $REV $REPOS
TRAC_ENV='c:\projects\trac'
TRAC_URL='http://localhost:8000/myproject2'
C:\Python24\python.exe C:\projects\svn\hooks\trac-post-commit-hook.py -p "$TRAC_ENV"
-r "$REV" -m "$LOG" -s "$TRAC_URL"

I am new to all of this. any help would be appreciated.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by cuong <duccuongbui8955@…>

  • Component changed from TracHacks to CacheSystemPlugin
  • Owner changed from athomas to coderanger
  • Priority changed from normal to highest
  • Severity changed from normal to critical
  • Type changed from defect to task

comment:2 follow-up: Changed 6 years ago by cuong <duccuongbui8955@…>

  • Component changed from CacheSystemPlugin to SvnChangeListenerPlugin
  • Owner changed from coderanger to k0s

comment:3 in reply to: ↑ 2 Changed 6 years ago by k0s

  • Priority changed from highest to normal
  • Severity changed from critical to normal

i'm not sure what the issue is here; does the post-commit script not work for you? in either case, it is NOT an issue for SvnChangeListenerPlugin, which does the identical task but in a different way; i think this ticket is invalid but will await more information

comment:4 Changed 6 years ago by k0s

  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from k0s. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.