Modify

Opened 6 years ago

Closed 6 years ago

#3562 closed defect (duplicate)

TypeError: previous_rev() takes exactly 2 arguments (3 given)

Reported by: anonymous Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

When displaying a changeset i got this error:

TypeError: previous_rev() takes exactly 2 arguments (3 given)

Changing git_fs.py line 252 from

def previous_rev(self, rev):

to

def previous_rev(self, rev, foo):

seems to solve the issue.

I'm not python programmer so i can't judge about this, just wanted to let you know.

Running python 2.5.2, trac 0.11, gitplugin revision 4146.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by marc

  • Owner changed from hvr to marc
  • Status changed from new to assigned

I can confirm that it works :)

comment:2 Changed 6 years ago by marc

  • Owner changed from marc to hvr
  • Status changed from assigned to new

Whoops did not want to change the assignment.

comment:3 Changed 6 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3008

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.