Modify

Opened 6 years ago

Closed 6 years ago

#3625 closed defect (duplicate)

"System can't find the file"

Reported by: jgoering@… Owned by: coderanger
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /depgraph/3300, Trac issued an internal error.

I simply set ticket 3300 as "blocked by" 3386. Then I tried to view the dependency graph from ticket 3300 and got this error. The translation of the error message is "the system can't find the file"

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

System Information

Trac 0.11.1
Python 2.4.4 (#71, Oct 18 2006, 08:34:43) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c8
SQLite 3.3.6
pysqlite 2.3.2
Genshi 0.5.1
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\main.py", line 219, in dispatch
    data, content_type)
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\chrome.py", line 715, in render_template
    return stream.render(method, doctype=doctype)
  File "build\bdist.win32\egg\genshi\core.py", line 179, in render
  File "build\bdist.win32\egg\genshi\output.py", line 60, in encode
  File "build\bdist.win32\egg\genshi\output.py", line 311, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 753, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 592, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 698, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 532, in __call__
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\chrome.py", line 767, in _strip_accesskeys
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\chrome.py", line 756, in _generate
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "build\bdist.win32\egg\genshi\template\base.py", line 569, in _include
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
  File "build\bdist.win32\egg\genshi\template\markup.py", line 245, in _match
  File "build\bdist.win32\egg\genshi\template\base.py", line 543, in _exec
  File "build\bdist.win32\egg\genshi\template\base.py", line 533, in _eval
  File "build\bdist.win32\egg\genshi\template\base.py", line 496, in _eval
  File "build\bdist.win32\egg\genshi\template\base.py", line 551, in _flatten
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "build\bdist.win32\egg\genshi\path.py", line 141, in _generate
  File "build\bdist.win32\egg\genshi\template\base.py", line 569, in _include
  File "build\bdist.win32\egg\genshi\template\markup.py", line 234, in _strip
  File "build\bdist.win32\egg\genshi\template\base.py", line 543, in _exec
  File "build\bdist.win32\egg\genshi\template\base.py", line 533, in _eval
  File "build\bdist.win32\egg\genshi\template\base.py", line 496, in _eval
  File "build\bdist.win32\egg\genshi\template\base.py", line 551, in _flatten
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
  File "build\bdist.win32\egg\genshi\path.py", line 141, in _generate
  File "build\bdist.win32\egg\genshi\template\base.py", line 569, in _include
  File "build\bdist.win32\egg\genshi\template\markup.py", line 234, in _strip
  File "build\bdist.win32\egg\genshi\template\base.py", line 543, in _exec
  File "build\bdist.win32\egg\genshi\template\base.py", line 520, in _eval
  File "build\bdist.win32\egg\genshi\template\base.py", line 286, in _eval_expr
  File "build\bdist.win32\egg\genshi\template\eval.py", line 180, in evaluate
  File "C:\Dokumente und Einstellungen\Default User\Application Data\Python-Eggs\tracmastertickets-2.1.3-py2.4.egg-tmp\mastertickets\templates\depgraph.html", line 22, in <Expression u"Markup(graph_render('cmapx').decode('utf8'))">
    ${Markup(graph_render('cmapx').decode('utf8'))}
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\util\compat.py", line 133, in newfunc
    return func_(*(args + fargs), **dict(kwargs, **fkwargs))
  File "build\bdist.win32\egg\mastertickets\graphviz.py", line 129, in render
  File "C:\Python24\lib\subprocess.py", line 543, in __init__
    errread, errwrite)
  File "C:\Python24\lib\subprocess.py", line 706, in _execute_child
    startupinfo)
WindowsError: [Errno 2] Das System kann die angegebene Datei nicht finden


Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jgoering@…

OK, the good news is: I'm an idiot. :)

I had not installed Graphviz... (d'oh)

Bad news is: still doesn't work (d'oh!)

now I get:

Traceback (most recent call last):
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\api.py", line 339, in send_error
    'text/html')
  File "c:\python24\lib\site-packages\Trac-0.11.1-py2.4.egg\trac\web\chrome.py", line 715, in render_template
    return stream.render(method, doctype=doctype)
  File "build\bdist.win32\egg\genshi\core.py", line 179, in render
  File "build\bdist.win32\egg\genshi\output.py", line 60, in encode
  File "build\bdist.win32\egg\genshi\output.py", line 311, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 753, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 592, in __call__
  File "build\bdist.win32\egg\genshi\output.py", line 707, in __call__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 4142: ordinal not in range(128)

comment:2 Changed 6 years ago by jgoering@…

  • Resolution set to duplicate
  • Status changed from new to closed

good news: duplicate of #3449 and #2658

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.