Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#3633 closed defect (invalid)

installed and wouldn't work

Reported by: vipaca Owned by: ashkulz
Priority: normal Component: FlatTableMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /wiki/ResultsPage, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'comment': u'', 'text': u'[[InsertElement(element, id, abuse, "<table border=1><tr><thead><td>Test</td><td>Status</td><td>Link</td></tr></thead><tr><td bgcolor=green>Create Interface</td><td bgcolor=green></td><td bgcolor=green></td></tr><tr><td bgcolor=green>Delete Interface</td><td bgcolor=green></td><td bgcolor=green></td></tr><tr><td bgcolor=red>Get Non-Statistical Interface Attribute</td><td bgcolor=red></td><td bgcolor=red></td></tr><tr><td bgcolor=red>Get Statistical Interface Attribute</td><td bgcolor=red></td><td bgcolor=red></td></tr></table>")]]\r\n\r\n\r\n{{{\r\n#!flat-table\r\n#! Name: key, Relation: relation, Comment: comment notes\r\n\r\nid:\r\n  @relation: PK\r\n\r\ndesc:\r\n  @comment: description\r\n\r\n}}}\r\n', 'editrows': u'20', '__FORM_TOKEN': u'5b2d7a0abba0fa99ea81a054', 'version': u'2', 'action': u'edit', 'preview': u'Preview Page', 'scroll_bar_pos': u'0', 'page': u'ResultsPage'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

System Information

Trac 0.11rc1
Python 2.3.4 (#1, Nov 4 2004, 14:06:56)
[GCC 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)]
setuptools 0.6c7
SQLite 3.3.13
pysqlite 2.3.3
Genshi 0.4.4
mod_python < 3.2
Pygments 0.11.1
Subversion 1.4.6 (r28521)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/main.py", line 417, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/main.py", line 219, in dispatch
    data, content_type)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 723, in render_template
    return stream.render(method, doctype=doctype)
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 154, in render
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 45, in encode
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 274, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 519, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 679, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 459, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 779, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 768, in _generate
    for kind, data, pos in stream:
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 252, in _include
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 322, in _match
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 252, in _include
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 297, in _match
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 286, in _strip
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 242, in _exec
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/base.py", line 421, in _eval
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/eval.py", line 136, in evaluate
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/templates/wiki_edit.html", line 1, in <Expression u'wiki_to_html(context(page.resource), page.text)'>
    <!DOCTYPE html
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/util/compat.py", line 130, in newfunc
    return func_(*(args + fargs), **dict(kwargs, **fkwargs))
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 1094, in format_to_html
    return HtmlFormatter(env, context, wikidom).generate(escape_newlines)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 1053, in generate
    escape_newlines)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 833, in format
    self.handle_code_block(line)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 764, in handle_code_block
    processed = self.code_processor.process(code_text)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 179, in process
    text = self.processor(text)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 166, in _macro_processor
    text)
  File "/repo/trac/xr-perf/plugins/FlatTableProcessor.py", line 79, in expand_macro
    config = self._parse_config([i.strip() for i in lines[0][2:].split(',')])
  File "/repo/trac/xr-perf/plugins/FlatTableProcessor.py", line 51, in _parse_config
    name, sep, val = col.partition(':')
AttributeError: 'unicode' object has no attribute 'partition'


Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description ; follow-up: Changed 6 years ago by anonymous

I just wanted to remark that the macro loaded even though in the bug report I created has that error. I got this because I pasted my trac content and the trachacks website does not support your macro.
Replying to vipaca:

How to Reproduce

While doing a POST operation on /wiki/ResultsPage, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{{{\r\n#!flat-table\r\n#! Name: key, Relation: relation, Comment: comment notes\r\n\r\nid:\r\n  @relation: PK\r\n\r\ndesc:\r\n  @comment: description\r\n\r\n}}}\r\n', 'editrows': u'20', '__FORM_TOKEN': u'5b2d7a0abba0fa99ea81a054', 'version': u'2', 'action': u'edit', 'preview': u'Preview Page', 'scroll_bar_pos': u'0', 'page': u'ResultsPage'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

System Information

Trac 0.11rc1
Python 2.3.4 (#1, Nov 4 2004, 14:06:56)
[GCC 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)]
setuptools 0.6c7
SQLite 3.3.13
pysqlite 2.3.3
Genshi 0.4.4
mod_python < 3.2
Pygments 0.11.1
Subversion 1.4.6 (r28521)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/main.py", line 417, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/main.py", line 219, in dispatch
    data, content_type)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 723, in render_template
    return stream.render(method, doctype=doctype)
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 154, in render
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 45, in encode
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 274, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 519, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 679, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/output.py", line 459, in __call__
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 779, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/core.py", line 212, in _ensure
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/web/chrome.py", line 768, in _generate
    for kind, data, pos in stream:
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 252, in _include
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 322, in _match
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 252, in _include
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 297, in _match
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 286, in _strip
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/markup.py", line 242, in _exec
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/base.py", line 421, in _eval
  File "/usr/lib/python2.3/site-packages/Genshi-0.4.4-py2.3.egg/genshi/template/eval.py", line 136, in evaluate
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/templates/wiki_edit.html", line 1, in <Expression u'wiki_to_html(context(page.resource), page.text)'>
    <!DOCTYPE html
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/util/compat.py", line 130, in newfunc
    return func_(*(args + fargs), **dict(kwargs, **fkwargs))
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 1094, in format_to_html
    return HtmlFormatter(env, context, wikidom).generate(escape_newlines)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 1053, in generate
    escape_newlines)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 833, in format
    self.handle_code_block(line)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 764, in handle_code_block
    processed = self.code_processor.process(code_text)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 179, in process
    text = self.processor(text)
  File "/usr/lib/python2.3/site-packages/Trac-0.11rc1-py2.3.egg/trac/wiki/formatter.py", line 166, in _macro_processor
    text)
  File "/repo/trac/xr-perf/plugins/FlatTableProcessor.py", line 79, in expand_macro
    config = self._parse_config([i.strip() for i in lines[0][2:].split(',')])
  File "/repo/trac/xr-perf/plugins/FlatTableProcessor.py", line 51, in _parse_config
    name, sep, val = col.partition(':')
AttributeError: 'unicode' object has no attribute 'partition'


comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to anonymous:

I think it's because you're using python 2.3, which the trac team has been removing planning to remove support for. Please try it again with trac 0.11.1 (which requires genshi 0.5) at the very least and check whether you get this same error.

AttributeError?: 'unicode' object has no attribute 'partition' is a problem

The partition method() was added in python 2.5 (see http://docs.python.org/whatsnew/other-lang.html) so if this error is present in trac 0.11.1, please file a bug report against trac itself.

comment:3 Changed 6 years ago by ashkulz

  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from ashkulz. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.