Modify

Opened 6 years ago

Closed 5 years ago

#3670 closed defect (worksforme)

0.11 gives AttributeError: 'NoneType' object has no attribute 'has_key'

Reported by: tarjei Owned by: athomas
Priority: normal Component: XmlRpcPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

Plugin version: downloaded the zip file on Sept. 5 and ran easy_install on the trunk directory.

Enabled all the plugins ++.

When I try to access the XMLInterface using VimTrac, the following error is reported:

[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend: Traceback (most recent call last):
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib64/python2.4/site-packages/mod_python/apache.py", line 299, in HandlerDispatch\n    result = object(req)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/modpython_frontend.py", line 128, in handler\n    gateway.run(dispatch_request)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/wsgi.py", line 87, in run\n    response = application(self.environ, self._start_response)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 394, in dispatch_request\n    return _dispatch_request(req, env, env_error)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 484, in _dispatch_request\n    req.send_error(exc_info, status=500, env=env, data=data)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/api.py", line 358, in send_error\n    exc_info)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request\n    dispatcher.dispatch(req)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 226, in dispatch\n    self._post_process_request(req)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 301, in _post_process_request\n    f.post_process_request(req, *(None,)*extra_arg_count)
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend:   File "build/bdist.linux-x86_64/egg/clients/client.py", line 29, in post_process_request
[Fri Sep 05 11:15:14 2008] [error] [client ip-changed] PythonHandler trac.web.modpython_frontend: AttributeError: 'NoneType' object has no attribute 'has_key'

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by osimons

  • Resolution set to worksforme
  • Status changed from new to closed

I don't see xml-rpc code anywhere in that traceback, and not sure what plugins and Trac version you have installed. The XmlRpcPlugin writes its return values directly to req, and I've recently improved error reporting so that any errors are returned using the same protocol as the request - and not try to render a regular HTML error page if any error occurs during method execution, which perhaps may have been the cause of this.

Please update to latest version from plugin trunk, and reopen if the problem persists - preferably with more information about your setup ('About Trac' versions table) and steps for me to reproduce your error. Also, be sure to enable and provide information from Trac debug logging as the plugin now writes a lot of status messages during processing.

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.