Modify

Opened 6 years ago

Closed 4 years ago

#3726 closed task (fixed)

Split admin panels in seperate components

Reported by: manski Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: permission separation admin
Cc: Trac Release: 0.11

Description

It would be nice if the admin panels "Configuration" and "Users" were in seperate components. This is useful when you have a Trac installation where you have several Trac projects of which you "trust" their admins (e.g. when providing a Subversion server with Trac support for everyone who needs it).

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by anonymous

Vote for this.

comment:2 Changed 4 years ago by sto

Seems that #5830 is a duplicate of this ticket.

I submitted ticket #7700 with a patch that kind of implements what you
want using a new permission to manage users without splitting the
modules (I don't give TRAC_ADMIN permission to project managers, but
they can administrate all they need with a set of *_ADMIN
permissions).

comment:3 Changed 4 years ago by hasienda

  • Keywords permission separation admin added
  • Owner changed from mgood to hasienda

I'll seek to implement both, the permission separation and hiding of admin pages accordingly, if this is not already taken care for by Trac itself.

comment:4 Changed 4 years ago by hasienda

#4671 has been closed as a duplicate of this ticket.

comment:5 Changed 4 years ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [9280]) AccountManagerPlugin: Allow acctmgr administration for non-TRAC_ADMINs, closes #3726 and #7700.

With dedicated AccountManagerPlugin permissions now you could not only
delegate AccountManager administration to users without granting them
TRAC_ADMIN, but even differentiate access policy within these settings
(closes #1902 as well):

  • ACCTMGR_CONFIG_ADMIN - for /config and /notification
  • ACCTMGR_USER_ADMIN - for /users
  • ACCTMGR_ADMIN - inheriting all without requiring TRAC_ADMIN

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.