Modify

Opened 6 years ago

Closed 3 years ago

#3729 closed defect (worksforme)

segfault on trac 0.11.1 with Include(source: ...

Reported by: anonymous Owned by: rjollos
Priority: normal Component: IncludeMacro
Severity: normal Keywords: needinfo
Cc: Trac Release: 0.11

Description

When I try to include a source text file, then my tracd, serving my local trac on WindowsXP, dies with a segfault.

e.g.

[[Include(source:trunk/epydoc.bat.txt, text/x-rst)]]

including regular Wiki pages is ok, with or without mime type.

all these issue reports on problems with trac 0.11 are pretty confusing. I don't know what the solution is and I don't want to spend a lot of time figuring it out.

Josef

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by coderanger

  • Keywords needinfo added

Does the source browser work?

comment:2 Changed 6 years ago by anonymous

source browser and IncludeSource.py macro that I kept from Trac 0.10 work without problems

[[IncludeSource(trunk/epydoc.bat.txt, text/x-rst)]]

additional info: I'm using authentication as described in the standalone trac description, and run trac with

python25 C:\Programs\Python25\Scripts\tracd-script.py --port 8000 --auth="*,digest.txt,trac" my-project"

Authentication could be the problem, since I require login to see the source, and the IncludeSource Macro ignores and violates the source view restriction. However, when I tried to use the TracInclude Macro/Plugin, I was logged in as admin with all rights.

I can try later today, if the TracInclude Macro/Plugin works if there is no permission restriction on source view.

comment:3 Changed 6 years ago by anonymous

Giving fileview and browserview permissions to anonymous does not change the segfault. I get the segfault each time I try to preview or save a wiki page with Include(source:..., whether I am logged in as trac_admin or not logged in at all.

comment:4 Changed 4 years ago by rjollos

  • Owner changed from coderanger to rjollos
  • Status changed from new to assigned

comment:5 Changed 3 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

I think this issue is most likely resolve with the latest 0.11 branch. Please reopen if you can reproduce with the latest revision of the trunk.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.