Modify

Opened 6 years ago

Closed 3 years ago

#3737 closed defect (worksforme)

custom dropdown list selection get lost on form commit via submit button

Reported by: cgrewe@… Owned by: hasienda
Priority: normal Component: TracFormsPlugin
Severity: normal Keywords: needinfo dropdown list
Cc: Trac Release: 0.11

Description

i used a dropdown list in a form with labels. When I select a value from the list and press the button submit_label it seems that the dropdown list get reset. The selected value gets lost. I did not understand that.

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by anonymous

  • Trac Release changed from 0.10 to 0.11

comment:2 Changed 3 years ago by hasienda

  • Summary changed from dropdown list in forms to custom dropdown list selection get lost on form commit via submit button

comment:3 Changed 3 years ago by rjollos

I'm almost certain I saw this same behavior with 0.11.

comment:4 Changed 3 years ago by hasienda

  • Keywords needinfo added

Could somebody else check this again, please? I've been unable to reproduce this with a recent development version from trunk in Trac 0.12 and 0.13dev.

Hint: Checkout the fresh release 0.3 (see [10143] for details).

comment:5 Changed 3 years ago by hasienda

I've put out an example in wiki:TracFormsPlugin/Starter now, that worksforme.

And I suspect, that the issue is related to improper variable naming or use of multiple forms per resource without proper subcontext command in place for each of these forms. It would produce exactly such a value reset, if pressing another form's submit button, effectively overwriting saved field values with values of that other form.

I'll work on further improving the documentation a bit and close this issue, if no more complaint is raised here within a couple of weeks.

comment:6 Changed 3 years ago by hasienda

I've tried to reach the reporter directly, but got no feedback.

As mentioned above, anything above 0.2.1 should be work, but I recommend the latest stable, currently 0.4, or trunk, since these branches/revisions have a much cleaner db handling - just to make sure, that there's no db side-effect involved.

Ryan, you mentioned you'd look at this code later on. Would you do me a big favor and check this at that time and close it, if you can't reproduce as well, please? Fair enough, because since the observation and report several hundred, if not thousand lines-of-code for this plugin have been changed.

comment:7 Changed 3 years ago by hasienda

  • Owner changed from rharkins to hasienda

(Take over the ownership of this ticket now to receive future comments.)

comment:8 Changed 3 years ago by hasienda

  • Resolution set to worksforme
  • Status changed from new to closed

Finally got an own test environment. Hereby I confirm, that this is working with Trac 0.11 and r10490 of the plugin.

BTW, it would have not worked with a newer version at least after changeset [10021] (introduction of i18n stuff) back in April this year. Good news: Trac 0.11 backwards-compatibility has been restored just by today. So go with tracforms-0.4.1 and have fun.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.