Modify

Opened 6 years ago

Closed 6 years ago

#3953 closed defect (duplicate)

I can't upload screenshots!

Reported by: sincoder Owned by: Blackhex
Priority: highest Component: ScreenshotsPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

I've installed this plugin and TracTags via easy_install svn and set trac.ini to

[components]
tracscreenshots.* = enabled

[screenshots]
path = /var/trac/screenshots

And I've also set permissions but I can't upload any images. There is a "add" button (no filebrowsebox if there should be one) but it only redirects me back to the screenshots display page.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by sincoder

  • Priority changed from normal to highest
  • Severity changed from normal to blocker
  • Trac Release changed from 0.10 to 0.11

comment:2 Changed 6 years ago by anonymous

  • Owner changed from Blackhex to anonymous
  • Status changed from new to assigned

What is your server and client? What is debug log from the event?

comment:3 Changed 6 years ago by sincoder

  • Owner changed from anonymous to Blackhex
  • Status changed from assigned to new
  • Summary changed from I can't upload images! to I can't upload screenshots!

My server is apache2 - don't know how to check the version but I CAN upload regular attachments. I have tried numerous clients and all FAIL to upload screenshots. My trac is here: http://snowhard.jovianvoid.com/screenshots - I have granted SCREENSHOTS_ADMIN prem to anonymous.

This is the only relevant info I can find in the debug log:

2008-10-22 07:24:54,836 Trac[__init__] DEBUG: SELECT value FROM system WHERE name='screenshots_version'
2008-10-22 07:24:54,837 Trac[__init__] DEBUG: SELECT value FROM system WHERE name='fullblog_version'
2008-10-22 07:24:54,838 Trac[__init__] WARNING: base_url option not set in configuration, generated links may be incorrect
2008-10-22 07:24:54,839 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/screenshots/css/screenshots.css'">
2008-10-22 07:24:54,839 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/js/jquery.js'">
2008-10-22 07:24:54,840 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/theme/pydotorg.css'">
2008-10-22 07:24:54,910 Trac[__init__] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2008-10-22 07:24:54,967 Trac[__init__] DEBUG: 21 unreachable objects found.
2008-10-22 07:24:54,993 Trac[__init__] DEBUG: 39 unreachable objects found.
2008-10-22 07:24:55,019 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:55,907 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/js/trac.js'">
2008-10-22 07:24:55,940 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:56,095 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/js/search.js'">
2008-10-22 07:24:56,129 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:56,338 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/screenshots/js/screenshots.js'">
2008-10-22 07:24:56,371 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:56,519 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/tracwysiwyg/wysiwyg.js'">
2008-10-22 07:24:56,548 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:56,918 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/theme/header-bg2.png'">
2008-10-22 07:24:56,955 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:56,957 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/site/snowhard_logo.png'">
2008-10-22 07:24:56,965 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/theme/button-on-bg.png'">
2008-10-22 07:24:56,990 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:57,011 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:57,013 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/dots.gif'">
2008-10-22 07:24:57,029 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/topbar_gradient2.png'">
2008-10-22 07:24:57,051 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:57,056 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/topbar_gradient.png'">
2008-10-22 07:24:57,064 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:57,089 Trac[__init__] DEBUG: Dispatching <Request "GET u'/chrome/common/trac_logo_mini.png'">
2008-10-22 07:24:57,093 Trac[__init__] DEBUG: 18 unreachable objects found.
2008-10-22 07:24:57,118 Trac[__init__] DEBUG: 18 unreachable objects found.

I have many plugins but ScreenshotsPlugin is the only one not working right now :(

comment:4 Changed 6 years ago by Blackhex

  • Status changed from new to assigned

Sorry, I should be more specific about what I need to know. Version is not much relevant to me as to know if it is apache+cgi, apache+fcgi or apache+mod_python. This part of debug log is not informative for me too. I need to see what happens after that. Anyway, I suspect that this ticket is duplicate of #3791. If you are using mod_python try to setup DocumentRoot accordingly and if this will not help you, then post your log, please.

comment:5 Changed 6 years ago by sincoder

  • Resolution set to duplicate
  • Status changed from assigned to closed

I'm using mod_python and Yes your right! #3791 (DocumentRoot) fixed this.

Thank you

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.