Modify

Opened 6 years ago

Closed 4 years ago

Last modified 2 years ago

#4011 closed defect (duplicate)

revision for wiki pages

Reported by: anonymous Owned by: coderanger
Priority: normal Component: IncludeMacro
Severity: normal Keywords: revision
Cc: Trac Release: 0.11

Description (last modified by rjollos)

Sometimes it is needed to include wiki pages of a special revision e.g. forms. It is needed because old already closed tickets gets changed if you update a form. This would destroy the traceability completely.

try:
  source_format, source_obj = source.split('#', 1)
except ValueError: # If no : is present, assume its a wiki page
  source_format, source_obj = 'wiki', source

try:
  source_obj, source_ver = source_obj.split(':', 1)
except ValueError: # If no : is present, assume its a wiki page
  source_ver, source_obj = None, source_obj

.
.
.

page = WikiPage(self.env, source_obj, version=source_ver)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by hasienda

  • Keywords revision added
  • Resolution set to duplicate
  • Status changed from new to closed

a duplicate of #3620, but I'll will publish the proposed solution there, so this may still lead to fixing this sooner, thanks

comment:2 Changed 2 years ago by rjollos

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.