Modify

Opened 5 years ago

Closed 5 years ago

#4074 closed defect (duplicate)

autocompleteusersplugin egg-building command fails unless package_data is edited in setup.py

Reported by: tom@… Owned by: k0s
Priority: normal Component: AutocompleteUsersPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I downloaded the 0.11 source zipfile.

When I attempt this:

python setup.py bdist_egg

I get this:

...
running build_py
error: can't copy 'autocompleteusers/htdocs/css': doesn't exist or not a regular file

If I modify setup.py as follows, changing htdocs/* to htdocs/*/*:

package_data={'autocompleteusers': htdocs/*/*?},

Then the egg building command succeeds and mentions the appropriate files along the way.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by fermulator

Confirmed.

comment:2 Changed 5 years ago by k0s

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3758; should be fixed as of r5047

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from k0s. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.