Modify

Opened 6 years ago

Closed 6 years ago

#4085 closed defect (worksforme)

server/trac/project/login page redirects to localhost/trac/project

Reported by: kekc.reg@… Owned by: mgood
Priority: high Component: AccountManagerPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

1) Then I'm loged in and go to page server/trac/project/login enter my credentials, it redirects me to localhost/trac/project. Which is not accessible of course.

2) Then I logout, then point my browser to server/trac/project, it redirects me to server/trac/project/login. Then I enter my username/password it redirects me to localhost/trac/project. Which is not accessible.

3) Then I logout, it redirects me to server/trac/project/login, I enter my credentials, and it redirects me to server/trac/project. It's OK so.

4) This is similar to 2) Then I just start the browser (IE or Firefox), I'm loged out, so then I enter page server/trac/project, it redirects me to server/trac/project/login. Then I enter my login/password it redirects to localhost/trac/project. So I see page 404 in IE and empty page in FF. I need to enter server/trac/project to have an access.

I use these components: Apache 2.2.8 Trac 0.11.2 NoAnonymous? 2.0 AccountManager 0.2.1dev-r4679 (AccountManagerAdminPage?, AccountManager, HtPasswdStore?, AccountModule?, LoginModule? enabled)

Notes: I must say, that then I disable NoAnonymous? plugin, it's not reproducible, but.. It's reproducible with both PermRedirect? and AuthRequired?. So I think this problem somewhere in redirection functions. IMHO.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by mgood

  • Resolution set to worksforme
  • Status changed from new to closed

You probably need to set the base_url setting in the trac.ini file so that it knows the correct domain name of your server. If you need more help please use the mailing list since this is likely a configuration issue, and not a bug in the plugin.

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.