Modify

Opened 6 years ago

Closed 6 years ago

#4102 closed defect (duplicate)

TracTweakUI插件不能正常使用

Reported by: hulm19 Owned by: ZoomQuiet
Priority: normal Component: ZoomQuietTranslation
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

ZoomQuiet你好! 我用的是0.11.1版的Trac,我用英文版直接安装TracTweakUI插件出错,信息如下: Traceback (most recent call last):

File "C:\Python24\Lib\site-packages\trac\web\api.py", line 339, in send_error

'text/html')

File "C:\Python24\Lib\site-packages\trac\web\chrome.py", line 683, in render_template

template = self.load_template(filename, method=method)

File "C:\Python24\Lib\site-packages\trac\web\chrome.py", line 659, in load_template

self.templates = TemplateLoader(self.get_all_templates_dirs(),

File "C:\Python24\Lib\site-packages\trac\web\chrome.py", line 406, in get_all_templates_dirs

dirs += provider.get_templates_dirs()

File "build\bdist.win32\egg\tractweakui\web_ui.py", line 52, in get_templates_dirs File "C:\Python24\Lib\site-packages\pkg_resources.py", line 840, in resource_filename

return get_provider(package_or_requirement).get_resource_filename(

File "C:\Python24\Lib\site-packages\pkg_resources.py", line 1311, in get_resource_filename

return self._extract_resource(manager, zip_path)

File "C:\Python24\Lib\site-packages\pkg_resources.py", line 1322, in _extract_resource

zip_stat = self.zipinfo[zip_path]

KeyError: 'tractweakui
templates'

请问是什么错误呢?安装步骤我是参考插件安装界面上的,而且我也有安装其他插件的经验。 希不吝赐教,多谢!

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by richard

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4495.

Add Comment

Modify Ticket

Action
as closed The owner will remain ZoomQuiet.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.