Modify

Opened 6 years ago

Closed 6 years ago

Last modified 7 months ago

#4143 closed defect (fixed)

OperationalError: (1054, "Unknown column 'started' in 'field list'")

Reported by: alex Owned by: daan
Priority: normal Component: ScrumBurndownPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

How to Reproduce
While doing a GET operation on /burndown, Trac issued an internal error. 

probably has something to do with the TestingWorkflow? plugin: http://trac-hacks.org/wiki/TestingWorkflow 

Request parameters: 

{'selected_component': u'All Components',
 'selected_milestone': u'Site beta version launch',
 'start': u'Start Milestone'}
User Agent was: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648) 

System Information
Trac  0.11.2.1  
Python  2.5.1 (r251:54863, Dec 7 2007, 23:58:55) 
[GCC 4.2.1 20070719 [FreeBSD]]  
setuptools  0.6c5  
MySQL  server: "5.1.22-rc", client: "5.1.22-rc", thread-safe: 1  
MySQLdb  1.2.2  
Genshi  0.6dev-r960  
mod_python  3.3.1  
Subversion  1.4.4 (r25188)  
jQuery:  1.2.6  

Python Traceback

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by alex

forgot the traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/web/main.py
Last edited 7 months ago by rjollos (previous) (diff)

comment:2 Changed 6 years ago by daan

  • Status changed from new to assigned

Hi Alex,

It looks like your milestone table does not have the 'started' column. Create this column by executing the following commands:

First, backup your SQLite database!

Open your Trac database with SQLite (execute 'sqlite3 trac.db')

Execute the following SQL commands:

CREATE TEMP TABLE milestone_old AS SELECT * FROM milestone;
DROP TABLE milestone;
CREATE TABLE milestone (
                 name            text PRIMARY KEY,
                 due             integer,
                 completed       integer,
                 started        integer,
                 description     text
        );
INSERT INTO milestone(name,due,completed,started,description)
        SELECT name,due,completed,0,description FROM milestone_old;

Let me know if it works..

comment:3 Changed 6 years ago by daan

  • Resolution set to fixed
  • Status changed from assigned to closed

Please reopen if this problem persists.

comment:4 Changed 7 months ago by rjollos

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from daan. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.