Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4245 closed defect (fixed)

AssertionError: Invalid action

Reported by: lore@… Owned by: coling
Priority: normal Component: ClientsPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

How to reproduce:

After installing ClientsPlugin, in WebAdministration, click on "Ticket System -> Client events"

Most recent call last:


    * File "build\bdist.win32\egg\clients\events.py", line 263, in select
      Local variables:
      Name	Value
      action 	u'Send Email'
      clev 	<clients.events.ClientEvent object at 0x0188A1B0>
      client 	None
      cls 	<class 'clients.events.ClientEvent'>
      cursor 	<trac.db.util.IterableCursor object at 0x0188A690>
      db 	<trac.db.pool.PooledConnection object at 0x0197B468>
      env 	<trac.env.Environment object at 0x01648350>
      lastrun 	None
      name 	u'Ticket Changes'
      summary 	u'Ticket Change Summary'
    * File "build\bdist.win32\egg\clients\events.py", line 149, in _load_options
      Local variables:
      Name	Value
      client 	None
      db 	<trac.db.pool.PooledConnection object at 0x0197B468>
      self 	<clients.events.ClientEvent object at 0x0188A1B0>
    * File "build\bdist.win32\egg\clients\events.py", line 124, in _load_client_options 
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Trac: 	0.12dev-r7697
Python: 	2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)]
setuptools: 	0.6c9
SQLite: 	3.6.2
pysqlite: 	2.5.0
Genshi: 	0.6dev-r960
Subversion: 	1.5.2 (r32768)
jQuery:	1.2.6

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

I'm sorry, I found the problem. It was because I don't check this:

ClientActionEmail
clients.action_email
	
ClientActionZendesk
clients.action_zendesk_forum

in component, plugin.

comment:2 Changed 5 years ago by anonymous

I should probably still make it a little bit more user friendly tho' :)

Hope you can use it OK... the docs are a bit thin on the ground.... /me has no time to update at the moment.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coling. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.