Modify

Opened 5 years ago

Closed 5 years ago

#4252 closed defect (worksforme)

Wiki-Links of ListOfWikiPages Macro contain a wrong URL

Reported by: falko.zurell@… Owned by: martin_s
Priority: normal Component: ListOfWikiPagesMacro
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

I've installed the ListOfWikiPagesMacro in my TRAC 0.11.2.1.
It's working in Principle but the links to the pages it generates contain a wrong URL.

My Trac Base_URL is /my-track (set in [trac] section of the trac.ini)

but alle the generated Links point to /my-track/my-track/Pagename.

So somewhere the base url seems to be doubled.

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by martin_s

  • Status changed from new to assigned

comment:2 Changed 5 years ago by martin_s

The correct usage of base_url is still a mystery to me. Should it be relative or absolute? When exactly is it used where? Trac needs better documentation here.

Did you tried it with an empty base_url? Works fine with me.

What setup are you using? Single or multi-project? Apache or standalone? What is your use_base_url_for_redirect setting?

comment:3 Changed 5 years ago by martin_s

I changed now ([5112]) the source code. Please try the latest version and tell me if the error disappears.

comment:4 Changed 5 years ago by anonymous

  • Resolution set to worksforme
  • Status changed from assigned to closed

I tried your new version. But it didn't change the behaviour. Then I looked at my base_url parameter and it was set to something like this:

base_url = /mytrac

I set this to empty:

base_url =

and the links are generated correct. So I'm not sure if this alone was the cause or if your changes and my change lead to the correct links. But as you said "base_url" at least has a major impact on that.

Thanks!

Falko

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from martin_s. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.