Modify

Opened 6 years ago

Closed 5 years ago

#4358 closed defect (worksforme)

[[BlogList]] macro does not reset text format

Reported by: oberrocker@… Owned by: osimons
Priority: normal Component: FullBlogPlugin
Severity: normal Keywords:
Cc: rjollos Trac Release: 0.11

Description

If the BlogList macro cuts the blog entry preview at a position with e.g. bold formatting, the entire rest of the wiki page is rendered in bold text (see screenshot).

Syntax used was

[[BlogList(recent=1, max_size=100, format=full)]]

Attachments (1)

blogbug.png (52.2 KB) - added by oberrocker@… 6 years ago.
screenshot

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by oberrocker@…

screenshot

comment:1 Changed 5 years ago by rjollos

  • Cc rjollos added; anonymous removed

comment:2 Changed 5 years ago by osimons

I've been testing this, and sometimes it resets - and sometimes it does not. For instance, if you cut the post at regular <p> level, regular bold text will be reset and don't carry into other sections. However, if that bold is part of a <ul><li> item (as your attachment:blogbug.png) it does not manage to reset.

I'm currently not quite sure where this is best fixed - it is partly a duplicate of #3069, but on the other hand it should not choke at page-level suggesting a bug in Trac itself. This also seeing the same is easily recreated with regular wiki markup only (no blog involved):

This line '''does not close bold.

No problems though as it resets. Lists won't though:
 * '''Not closing bold...
 * Bold Continues here...

This will be bold too as will the rest of the page...

comment:3 Changed 5 years ago by osimons

comment:4 follow-up: Changed 5 years ago by cboos

As I just fixed #T3232, I'd be curious to know if this also fixed this one.

comment:5 in reply to: ↑ 4 Changed 5 years ago by osimons

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to cboos:

As I just fixed #T3232, I'd be curious to know if this also fixed this one.

Thanks Christian, it did fix it - limiting the effect to the list item. Goodie. Isn't really anything more to do with this ticket, so closing as 'worksforme' seems the best option.

Add Comment

Modify Ticket

Action
as closed The owner will remain osimons.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.