Modify

Opened 6 years ago

Closed 5 years ago

#4494 closed defect (duplicate)

[Patch] Throws an exception when used with the GitPlugin

Reported by: me+trac@… Owned by: athomas
Priority: normal Component: ChangeLogPlugin
Severity: normal Keywords: git
Cc: Trac Release: 0.11

Description

The exception is:

2009-01-21 19:16:18,632 Trac[formatter] ERROR: Macro ChangeLog(/, 5) failed
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/wiki/formatter.py", line 467, in _macro_formatter
    return macro.process(args, in_paragraph=True)
  File "/usr/lib/python2.5/site-packages/trac/wiki/formatter.py", line 178, in process
    text = self.processor(text)
  File "/usr/lib/python2.5/site-packages/trac/wiki/formatter.py", line 165, in _macro_processor
    text)
  File "/home/svn/donator.trac/plugins/changelog.py", line 50, in expand_macro
    out.write(wiki_to_html("'''[%i] by %s on %s'''\n\n%s" % (nrev, change.author, format_datetime(change.date), change.message),
TypeError: int argument required

Since nrev is not an int in Git, the %i conversion fails. Patch attached.

Attachments (1)

4494.diff (674 bytes) - added by me+trac@… 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by me+trac@…

comment:1 Changed 5 years ago by me+trac@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of 4034.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.