Modify

Opened 6 years ago

Closed 5 years ago

#4497 closed defect (wontfix)

Trac-Admin Upgrad Breaks my Database!!!

Reported by: bjackman@… Owned by: khundeen
Priority: highest Component: TracMetrixPlugin
Severity: critical Keywords: userwarning matplotlib before upgrade tracmetrix cache
Cc: Trac Release: 0.11

Description (last modified by khundeen)

After installing the plugin and all the dependencies (matplotlib, numpy, pygtk, etc) I executed trac-admin /path/to/environment upgrade and got the following:

/usr/lib/python2.5/site-packages/matplotlib/__init__.py:753: UserWarning:  This call to matplotlib.use() has no effect
because the the backend has already been chosen;
matplotlib.use() must be called *before* pylab, matplotlib.pyplot,
or matplotlib.backends is imported for the first time.

warnings.warn(_use_error_msg)
TracMetrix Plugin needs an upgrade
creating cache folder
Done Upgrading
Upgrade done.

Now my entire project fails to load in a browser. Apache issues a 500 error. Disabling the plugin in trac.ini does not affect this.

Please help!!! My Entire Project is Broken!

Attachments (1)

Clipboard02.jpg (37.0 KB) - added by bjackman@… 6 years ago.
screenshot

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by bjackman@…

screenshot

comment:1 Changed 6 years ago by bjackman@…

Also, if I go to the trac parent environment directory I see errors. Please see attached screenshot.

comment:2 Changed 6 years ago by bjackman@…

  • Severity changed from blocker to critical

I have managed to get the project working by removing the .egg file. Reducing severity.

comment:3 Changed 5 years ago by khundeen

  • Description modified (diff)

The error caused by the Matplotlib. I removed the logic for this. Please try again.
Let me know if you still have problem.

comment:4 Changed 5 years ago by anonymous

Unfortunately, our company is not using Trac any longer (too bad, I know). So I cannot confirm this fix.

comment:5 Changed 5 years ago by khundeen

  • Resolution set to wontfix
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from khundeen. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.