Modify

Opened 5 years ago

Closed 4 years ago

#4512 closed enhancement (worksforme)

Make AcronymDefinitions URLs wiki friendlier

Reported by: zeljko Owned by: rjollos
Priority: normal Component: AcronymsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

AcronymDefinitions expect full or relative URL, but relative URL should be wiki page.

For example:

||Test||Test Page||TestPage|| ||

will point to
http://host/trac/project1/TestPage
which is wrong, because address of wiki page is
http://host/trac/project1/wiki/TestPage

In short, relative links are HTTP relative, not wiki relative.

It works if written like this:

TestTest Pagewiki/TestPage

Attachments (0)

Change History (3)

comment:1 follow-up: Changed 5 years ago by anonymous

Doesn't work for tickets

Current URL handling causes problems for acronyms in tickets, too: URL for "MessageFormatLanguage" is

http://osir123x/trac/soa-prototype/ticket/wiki/MessageFormatLanguage

(note "ticket") and it should be

http://osir123x/trac/soa-prototype/wiki/MessageFormatLanguage

comment:2 in reply to: ↑ 1 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos
  • Status changed from new to assigned

Replying to anonymous:

Doesn't work for tickets

This is the same issue as in #6824, and will be dealt with in that ticket.

comment:3 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce with Trac Trac 0.11.8dev-r9998. Adding Test to SandBox points to http://localhost:8000/tracdev/wiki/SandBox. The only thing I can think is that it might have something to do with my running Tracd in a dev environment and not mod_wsgi. Please reopen if you can reproduce with Trac 0.11.7.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.